New Release - Firmware Version 2.05.08 for WD TV Live Hub (4/12/11)


#1

WD is happy to announce our latest firmware update for the WD TV Live Media Player.  

 

 

Please post your experiences here in this thread.  


#2

still horrible bug not fixed, really ticked off.

videos when paused go back to the menu while stile playing in the background.

ive reset back to defaults, done the paper clip thing, unplugged for 10+ mins, still doesnt fix it


#3

Still no 5.1 PCM passthrough for movies XD


#4

Ok it appears you’ve made Netflix MUCH worse to deal with. It’s no longer possible to easily see the names because you removed them, completely re-organized and made it so you have to highlight one to actually see wtf it is, and then wait for your delayed info bar to actually show what it is.

Also, navigation is slow as dirt.

And finally, it is now consistently hard-freezing the device just simply navigating netflix generally. Also happened while watching a stand-up on netflix. Just a hard freeze. Had to unplug the device 3 times over the last 30 minutes while trying to use the netflix service with this latest firmware.

I assume BETA firmware never automatically downloads and therefore this is considered production / RC?? I’m thinking no… looks like netflix is destroyed until I find the previous version of firmware and undo this latest update.

Sorry if I sound annoyed, but, I’m annoyed.


#5

IronSpine: The Netflix UI is written by NETFLIX, not WD, so mind your manners.


#6

Mind my manners? If describing what I’m experiencing after this latest update makes you tear up then grab a napkin or something. This isn’t about being nice or mean. It’s about defining the behavior of the equipment post-update.

And if it’s Netflix that did it and not WD, then either forward it to the correct team so they can see it or provide an appropriate link for posting “results” and I’ll do it.


#7

I appreciate the firmware upgrade, but as I live in Australia I won’t benefit from any of the new services and I wasn’t suffering from any of the bugs.

How about bumping the terribly slow UI up the priority list, and fixing the abysmal content info search? :slight_smile:


#8

Hi there.

I just purchased the WD TV Live Hub today and tried upgrading the firmware on my television using the latest firmware below via external usb flash drive.

2.05.08

However, when the frmware finishes installing on my hub, the UI interface of the WD TV Live Hub does not calibrate well to my television. The UI screen cuts off on the left side of my television and there are no settings I could choose to calibrate the UI to the full screen again.

The television I am using is the following:

LG  Plasma DU-42PX12X

I am also unable to reset the hub to its factory settings anymore to revert back to the previous UI.

Please advise as to what I should do next?


#9

Ok,thankx for this update. What about new views? 


#10

I will test some of the m2ts movies that previously wouldn’t play, but the “The” sorting thing and the UI having a 20+ second delay every 9 screens/63 movies makes browsing a pain with a large library.


#11

I am unable to use Netflix since updating. I deactivated the hub on my Netflix account and have tried to reset the services on the hub but I don’t think the “reset all services” option is resetting anything. When I try to access Netflix it says “connecting to Netflix…” then “Retrieving files…” and then I get a message saying it cannot connect and I should try again later. Any ideas, I really don’t want to reset the entire hub.


#12

Are at lest basic HDMI CEC features implemented in this release?


#13

BUG whit brighness or overshadow in PREVIEW_MODE video


#14

No Country for Old Men is playing fine, which previously it wouldn’t (folder structure BD backup).


#15

Can we have some instructions on how to use the parental control?


#16

with the new firmware v.2.05.08, you remove the 12 bit. In Setup \ HDMI Deep Color mode, now I was only on 8 bit the quality is bad, you can not activate the 12 bit


#17

I managed to resolve this issue by downloading previous version of the firmware ( 2.04.13 ) and installing this firmware for my televison model ( LG  Plasma DU-42PX12X ),

However, the 2.05.08 firware made the UI go beserk on my televison screen (screen would flicker with no UI) and the only way I could reset the unit with a previous firmware was to do it through seperate television (old CRT JVC).


#18

Hey guys…I posted this on a similar forum as well, but maybe this might help in regards to the UI and image issues. I had the same problem with both a washed out/gray screen and the image being off-balance after the update to 2.05.08, plus it kept saying “upgrade incomplete” upon restart. I tried everything and nothing worked. That being said I have another live hub upstairs, and it upgraded fine. When I saw that, I realized that the hub upstairs was hardwired to my router, while the one with problems was wireless. Figuring it couldn’t hurt to try upgrading the one with issues via a Ethernet cable to my router, (as opposed to wireless) I went ahead and tried it. Problem solved! My screen was sharp and not washed out anymore, the off-kilter image was fixed and the upgrade was listed as “complete”. It confused me at first because in the “about” part of settings, it said the hub was fully upgraded, but it wasn’t. The hard wiring allowed the second part (listed as 2/2) to install. I went back to wireless after I did the upgrade, and everything worked perfect. Hopefully that may assist you. Was a weird issue, but Im glad all I lost was a few minutes.


#19

pauld wrote:

Can we have some instructions on how to use the parental control?

Set a password.

Then it will show you all the installed SERVICES.

Select whether or not you want to restrict those services.

On RESTRICTE services, if a user selects it, it will prompt for a password FIRST, before the service will start.

There’s also a FOLDER LOCK function which achieves the same type of thing for specific folder on the internal drive.


#20

Netflix had to re-login.  Like the new setup and they are correct it does take some time to have a movie to show up before it plays, however its better than having to re-start the movie when it starts up fast and shutsdown.  Just like a WII on wifi starting a movie.  I assume all other online services will have changed and need to see what else works,  does not work.  Need to check my playon server as well.  Will report all issues as they come and give positive and negative issues as well.