New Release - Firmware Version 1.13.18 for WD TV Live Streaming Media Player (1/24/13)

WD is happy to announce our latest firmware update for the WD TV Live Streaming Media Player.

If you experience any issues with this firmware, please report them in the WD TV Live Streaming Issue Reporting exchange.

For questions or sharing your experience, you can post in this thread.

1 Like

Hi all

Just registered to report I have just updated to this latest firmware and now no longer have Iplayer, was this deliberate or is there a way to get it back?

I have another one in another room and won’t be updating it if it loses iplayer.


Go to Setup / System Settings (i think) / RESET LOCATION

… and see if that fixes it.

Thanks for the rapid response,

That fixed it so very happy:smileyvery-happy:, I will now update my one in the lounge once again thanks


Finally 32x FF/RW which it should have had at the very start.

Takes longer to come out of standby and now WD logo pops up saying “Connecting to Network”.

Issue to report.

Just updated to the new firmware and lost ability to connect to network drives.

I have verified they are connected to the network, nothing has changed on the server I am trying to access.

I have reset to factory twice to resolve.  When selecting Network Share => Windows Share it just sits there spinning,  I have waited for it for 10 minutes. and nothing.


Great update! 3 months for this? The SMP STILL compiles the media library after its powered on… it’s been doing this for at least 2 hours so far! Performance of the SMP is still slow and annoying! Oh, and I love browsing my movies and the screen saver appearing! 

Thanks WD!!

@ daowen

Did you do the recommendations at the end of the release notes?

Problems during or after firmware upgrade

Please try some of these methods to resolve the problem you are experiencing. Try each method

to see if it fixes your issue before progressing to the next method.

Network specific issues:

  1. Redo Network Setup: Settings/Network Settings/Network Setup.

  2. Clear your Network Shares logins: Settings/Network Settings/ “Clear login info for

Network Share.” Then re-login.

All issues:

1.  Reset your unit through the user interface: Settings/System settings/”Reset to factory

defaults” OR hard reset by momentarily pressing a pin in the “Reset” hole on the bottom

of the WD TV unit.

  1. Delete the “.wd_tv” folder from your USB attached Hard Drive using a PC. Reattach

USB to the WD TV.

Am I missing something here ?

A New Firmware is released and with it instructions on how to fix problems ???

Well, I’ll give it a go and install it …

To my knowledge, they’ve always been there.

Just updated from 11.1 to the new version.

Works well and did not have to reset any setting for network or Netflick.

No Problems.

Regards, Rick

Well, just installed and all systems go ?  …

Are the colours more vibrant ?

hi I’ve just updated my firmware and I didn’t like any of its changes, especially when watching an online video, after the first minute, the image starts to cut off. Can anyone help me solve this or how to go back  to the previous firmware? Thanks

I was hoping for the addition of Amazon Video or Music Unlimited since I pay for both of those.

Is there a way we can vote on what is added next? Or at least let WD know that we do want these?

I registered just to say that after I updated to this firmware none of my movies on my external HD will play. I can start a movie and it says “No audio” in the top left corner and instead of the 111 minutes the movie is supposed to be the timer says 18:18 and then I get a fuzzy pixelated screen. They are all .m4v files and they played just fine earlier this week.

I have tried reseting by pushing the button on the bottom and tried the deleting the media library and letting it rebuild. neither helps.

About half of my Xvid .AVI no longer play. Says codec no supported.  Worked great pre-update.

= /

Also, when fast forwarding/rewinding 32x it shows >> X… instead of X32.

Not a big deal, but it should probably be corrected at some point.


can you post media info?


What video/music container that you have missing “X” for 32X FF?

MPEG-4 (Base Media / Version 2)

1 Video Stream: AVC

1 Audio Stream: AAC

1 text stream: Apple text

1 900 Kbps 720*460 (1.85:1) at 24.248 fps, AVC (Main@L3.0) (CABAC / 2 Ref Frames)

English, 160Kbps, 48.0KHz, 2 Channels, AAC (LC)