New My Cloud Unable to Connect


I purchased a new My Cloud for my business and am attempting to connect it to my network. All of the connections are good but the WD software does not recognize the drive during install. The device I am trying to connect to is a ubee modem/router and the ISP is Brighthouse.

We currently have these other devices connected via cable to the modem/router that are working just fine:

  •  Windows 7 Computer
  • Sprint Airave
  • WB Network Drive
  • Second window 7 laptop

Any ideas on how to get this thing up and running?


You dont really need to use the software.  Once the LED is blue, try accessing the dashboard by typing the URL into your browser:  http://wdmycloud/

I am facing the same issue. Running Windows 7, 64 bit.

I can go to the device page by keying in the ip address, but if I try  start > run and then \wdmycloud I get a device not found error.


Appreciate any help.

DS_WDMyCloud wrote:

I can go to the device page by keying in the ip address,


Do you mean typing in the ip in your browser to access the Web UI?

Open the Web UI and make sure that the device name is “WDMyCloud” in Settings>General

And under Network make sure that the Workgroup matches that of the workgroup of your PC.

I have the default settings, haven’t changed anything.




The following is what I see under Network, in windows explorer. So I can right click on this and open the device webpage. But if I double-click on the following icon nothing happens.

Also from Start > Run if I key in \WDMyCloud I get the network error message that I had posted earlier.


Thanks for your time and help.

So does it show up as a Computer under Network?


Also, you can try this.  Open an Explorer Window (not IE) then in the address bar type in the IP address of the My Cloud.

ie: \

Tyring flushing your dns.  Open command prompt, type: 

ipconfig /release

ipconfig /flushdns

ipconfig /renew

in that order

No this does not work. It does not show up as a computer under network.

I get the network error if I key in the ip address in windows explorer.

Also tried ipconfig commands suggested in the post above, but no luck. 

I re-tried the setup - mc_windows_setup.exe, so I am getting the following message.

open command prompt and type:   ping wdmycloud

if you get a reply, you’ll see the ip address of the wdmycloud, if not, then there is a network issue. Try rebooting the my cloud.