Cannot connect to mycloud


I’ve had my wdmycloud for a few months and all went swimmingly, but recently I have been unable to connect to it, and dashboard won’t see it. I have tried looking for it through the router interface but it just doesn’t appear at all. I have changed cables and ports, all to no avail. I have turned it on and off again (had to pull the plug as I couldn’t actually access it to turn it off that way). Any ideas gratefully received.


I’m living this dream right now. It would be nice to know if you get any traction on this. For me, all was well, then I tried to do the WD app, found I forgot my login, then asked what to do, I was told “reset” and now I am in limbo. Gah.

WD sent me the following information.  My WDmycloud seems incapable of a hard reset however, so will be replying to them  Will let you know if I have any more luck.

"Thank you for contacting Western Digital Customer Service and Support. My name is [Deleted].

I apologize for the inconvenience you are experiencing with your device.

Could you please let me know what operating system do you have?

If you have Windows, please check if you can access the WD My Cloud by using the WD Discovery utility. You can find the instructions how to do it on the link below:

If you cannot access the data by using the “Map network drive” function, but you can see the unit listed, please access the Dashboard of the My Cloud:

In the Dashboard, please try to restore the operating system of the device. You can do this by following the instructions on the link below:

From the table, please select the option “WD My Cloud System Only Restore”. This will only restore the settings and the operating system of the device, without deleting the data on it.

If the My Cloud does not appear in the WD Discovery, or you have a Mac, please perform the system restore of the My Cloud manually. It is possible to perform a System Only factory restore physically. At the same time as the power adapter is plugged to the WD My Cloud device, press and hold the Reset button on the back of the device for about 40 seconds. This process will not touch the data on the network drive.

If you have any further questions, please reply to this email and we will be happy to assist you further."

So i e-mailed WD back adn said their solution didn’t help. THey advised to turn it off and unplug everything for at least 10 minutes.

I left it off for a few hours and hey presto, I can see it all again. Haven’t fully checked it’s all working but at least my PC sees it again.