New My Cloud 4TB Question

I have a new MyCloud 4TB coming tomorrow.  I have to be honest in saying that if I would have looked at this forum first I “might” not have ordered one!

It seems from reading here that many issues have come up after the firmware update.  Not sure what mine will have but was just thinking how I might possibily prevent it from updating automatically.  I “assume” that an auto update is the default setting.  Will/would I be able to set it up before that happens?

I was also thinking of disconnecting my router from the outside world to prevent that from happening.  Any comments?

Yes, you can disable auto update.

However, you’ll need to determine if it’s worth it… check out the release notes to see what bug fixes and features you’re opting out of by not upgrading.

Also keep in mind that most people posting in forums are people that are having issues.  A few will chime in and say that it’s working well – but for most people that aren’t having issues, there’s no reason to register and post.  The vast majority of users are likely not having issues.

Take a look at this, My Cloud│How it Works and the User Manual. You should not have any problems setting it up.

When I did the last update it took about 30 minutes to download, install and reboot.

Posted by,
cat0w (USA)

You can disable auto-update a) in the control panel, b) by deleting the auto-update script and c) by blocking the My Cloud from accessing the internet in your router.

Thanks guys!  I already downloaded the update, manual and watched a few YouTube videos on it.  I’ll add to this thread as to how it all goes.

I’d read this thread, and take note of the comments about not needing to download any WD software to setup the mycloud (despite what the User Manual says); just use the Dashboard browser UI:

Took longer to open the boxes for the MyCloud and Gigabit switch than to get to work or so I thought!

I’m using W7/W10TP on a dual boot setup.  It shows up but I can’t C/P or drag files to it.  Found a setup mistake still no joy.  After fiddling around I booted into W7, altogether different, doesn’t show up the same but was able to C/P to it.  Back to W10TP, checked for updates and I had a MyCloud update for W10TP.  Oh boy!  Still no go but tried to get to it as in W7, at least I get a no access with a error that it can’t find a access path!  Tried to add device and that failed.  Needs something special but then W10TP is a beta so it may have an issue???

Might be sililiar to W8.1 which I’ve never used.  Might try the Windows Ten Forum unless you guys can come up with something to try.

In Windows 10 you need to add this to your registry to access the My Cloud:

Use RegEdit

  1. Create a Dword called ‘AllowInsecureGuestAuth’ in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

  2. Set the new value to 1

  3. Then close Regedit and Reboot.

1 Like

SectorGZ wrote:

In Windows 10 you need to add this to your registry to access the My Cloud:


Use RegEdit


  1. Create a Dword called ‘AllowInsecureGuestAuth’ in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
  1. Set the new value to 1
  1. Then close Regedit and Reboot.



That worked!  Thanks

Using LAN Speed Test from Totusoft without their server.

Getting 500, 600, 700 and 800 Mbps in W7 but first test in W10TP, I get 8 Mbps!  That looks like Fast 10/100 speed but was actually pleased with the W7 speeds as I not sure what’s good for gigabit speed in my system.

Is there something in the W10TP settings that is killing the speed?  Not sure about the LST with W10TP either!

I just emailed Totusoft asking about W10TP possible issues.

Agreed. This is not the type of forum to say things are great. What you read here likely only affect a small subset of users.

From my 18 years of IT experience I have learned, for my personal tech, never to do a firmware upgrade unless the release notes specifically address an issue I am having or adds new functionality I desire or a security patch I feel is needed. Otherwise my feeling is “if it ain’t broke don’t fix it”… Lastly never immediately upgrade to newly released firmware. I always wait a mimimum of 7-10 days to make sure it’s not retracted or a fix issued

On the LAN Speed Test, the author had me try his Lite version in W10TP which gave much different results but I haven’t heard back from although he stated that W10TP hasn’t even been looked at yet.