New MKV files are Evil!


#1

After doing some reading and testing some setups I’ve found out what is killing my Live TV. It’s the new MKV files built with MKVtoolnix 4.2.0 and most likely the mkvmerge part. These files are either a new standard or unstandard and the Live TV player really doesn’t like them.

Here’s what I’ve found. If I start my LT and chose a video file it will happily play. But if I try to play a new MKV, or even highlight it enough for the preview to try and start it kills the system. If I try and play the MKV I get the spinning ring and after 3 minutes I got feed up and the only thing that works is Back. The trouble is now all video files won’t play. To get them back I had to hard reset my LT. My guess is the new files put the decoder in a state that it doesn’t naturally recover from.

So easy fix is reset your machine and stay away from the new file type until WD give us a new firmware. Hard fix, if you really must watch that file, download MKVtoolnix, start the mkvmerge GUI, load your file, then highlight the the video track, from the extra options tab change the compression to none. Then highlight the audio track and do the same. You can now start muxing. It will take 2 minute to ??? depending on your PC and processor.

This last part is also usefull if your using the old player without DTS support and using the great MKV2VOB. If you feed a new style MKV in MKV2VOB will crash, do the toolnix thing first and it will work.

Hope this solves some peoples problems as it drove me wild.


#2

Heh… Known for almost three months now…  It’s even in the FAQ… :wink:


#3

Yeah, but *some* people don’t read the FAQ (some?)


#4

RedLeg wrote:

After doing some reading and testing some setups I’ve found out what is killing my Live TV. It’s the new MKV files built with MKVtoolnix 4.2.0 and most likely the mkvmerge part. These files are either a new standard or unstandard and the Live TV player really doesn’t like them.

 

Here’s what I’ve found. If I start my LT and chose a video file it will happily play. But if I try to play a new MKV, or even highlight it enough for the preview to try and start it kills the system. If I try and play the MKV I get the spinning ring and after 3 minutes I got feed up and the only thing that works is Back. The trouble is now all video files won’t play. To get them back I had to hard reset my LT. My guess is the new files put the decoder in a state that it doesn’t naturally recover from.

 

So easy fix is reset your machine and stay away from the new file type until WD give us a new firmware. Hard fix, if you really must watch that file, download MKVtoolnix, start the mkvmerge GUI, load your file, then highlight the the video track, from the extra options tab change the compression to none. Then highlight the audio track and do the same. You can now start muxing. It will take 2 minute to ??? depending on your PC and processor.

 

This last part is also usefull if your using the old player without DTS support and using the great MKV2VOB. If you feed a new style MKV in MKV2VOB will crash, do the toolnix thing first and it will work.

 

Hope this solves some peoples problems as it drove me wild.

No need to go wild its all here.

http://community.wdc.com/t5/General-Discussions/WDTV-FAQ/td-p/32135#playback

Section 4H

and here

http://www.bunkus.org/videotools/mkvtoolnix/faq.html#header_removal_compression


#5

Fair enough, you’re right it does mention it in the FAQ and I hadn’t read it. :smiley:

What it didn’t say I don’t think is it can create an instability that can carry over to playing other files. But yep you’re ‘Read the FAQ first’.


#6

RedLeg wrote:

Fair enough, you’re right it does mention it in the FAQ and I hadn’t read it. :smiley:

 

What it didn’t say I don’t think is it can create an instability that can carry over to playing other files. But yep you’re ‘Read the FAQ first’.

The hanging up of the WD live is covered in a multitude of other posts on this subject. In fact this has now become the easiest question to answer. Anyway thanks for the input and don’t let this stop you from posting on any other issues. They haven’t all been discovered by any means.