New firmware... help! the partitions of my hard disk don't work!

Hi! I decided after two years to upgrade my wd tv hd media player that worked perfectly with the firmware versione 1.04, with the last firmware but now the system only recognizes one of the three partitions of my toshiba external hard disk!!! I also tried to reinstall the previous firmware but it remains the problem!!! is it possibile to develop a new firmware that increases the problems?!!! (my hard disk is formatted in windows vista system). can you help me please!! thanks!

Ivan_762000 wrote:

Hi! I decided after two years to upgrade my wd tv hd media player…

What’s the exact model number of your player?   The device you name, the “WD TV HD” hasn’t been supported in a long time, and I don’t think there was ever a 1.04 firmware for it.

Try a Factory Reset to Defaults (in the Setup) and reboot

I have this model

wd tv live hd media player, I took this some years ago. I have used the last release 1.06 but also using now the 1.05 or 1.04 doesn’t solve the problem… help!!! The hard disk was perfectly recognized in its 3 partitions before the upgrade, so it’s cleary a problem of this firmware…

I would first connect the drive to windows and run check disk on all partitions

generally the WD will not mount any partition that is flaged dirty

usually due to improper shutdown or disconnect of hdd without first ejecting it

The forum for your WD model is here: