WDTV does not play movies

I have two 1,5TB External HardDisks. One from Medion and one from Western Digital.

I had a lot of movies and pictures on both drives, but then all of the sudden, my WD TV Live doesn’t want to play any movies or show any pictures.

I can still view the files on my computer, but I can’t play them using the WDTV.

I tried to update the firmware, but I can’t connect my network cable to it. I read it could be done manually too here: http://www.wdc.com/en/products/wdtv/

So I downloaded the latest firmware files (wdtv.bin and wdtv.ver), put them in the root of my HDD and tried to go to settings -> firmware update. But there wasn’t anything like that. I’m stuck now and one of my harddisks doesn’t work anymore. I already have the WDTV for a long time, and I wonder what broke it all of the sudden.

It is using firmware 1.01

Thanks in advance. I hope there is a solution for my problem.

Well this is the WDTV LIVE forum so you probably won’t get much help here. You need to go here-

http://community.wdc.com/t5/WD-TV-DVR-Expander/ct-p/wdtv

What WDTV version do you have? There are a few WDTV HD gen1, WDTV HD gen2, WDTV Live, WDTV Live Plus.