WDTV Firmware Update

I have a WD TV which I need to update its firmware manually as when I get to check it whilst connected to network, it prompts that it is up to date. Currently, the F/W version shows as 1.02.17.
I have checked the WD Support and found out that this version doesn’t even show at the bottom of the list. In fact the list starts at 1.04.12…!
The most recent version available is 2.01.86, which I have downloaded and unpacked on the USB flash drive in the ROOT, but I cannot get the WDTV to read the files. I have also tried both USB ports, front & back. WD Support online shows a set of instruction guides with screenshots, etc., but I don’t get those screenshot options. The only way that I know and have attempted trying to update the F/W is via the Settings > System > Check for F/W update, and each time I try to do this; it just wants to look for the update via the network/internet. I have even disconnected the unit from the router. I have reset the unit , restarted the unit with the USB already connected and connected after the boot up, but no joy…!?
I would greatly appreciate and welcome any help over this topic.
Thanks - Paskal

You’ve got your devices confused. (Firmware 1.04.12 & 2.01.86 are for the WDTV Live Streaming Media Player)

Firmware 2.02.32 is the latest firmware for the WDTV Live Streaming Media Player (2011)

Firmware 1.02.17 is the latest firmware for the WDTV Media Player (2014)
(Which is your Device … eg. this Player does not have Netflix, the other one does)

The firmwares are not cross compatible

Thanks for your response, JoeySmyth.
My device is the WDTV Media Player (2014) and does not have Netflix. You’re absolutely right as you have pointed out in the above. I had picked the wrong F/W update for my device…!

After having rechecked the firmware list on the WD Support, I noted that I had selected F/W file from the WD TV Live Streaming Media Player column. There are only 2 F/W update files showing for my WDTV Media Player, 1.01.30(most recent) and 1.00.42(previous). I don’t see the 1.02.175 to which you had referred above. My firmware is already showing on 1.02.17. I was hoping that there was a newer version to resolve an issue I am currently having with my device.

Once again, thanks for your help…!

1.02.17 released December 2014 is the Latest (Last ?) Firmware

What issue are you having ?

Sorry for not getting back to you sooner, JoeySmyth.

The issue that I am experiencing with my WDTV Media Player is a weird one, which I was trying to put into words to describe. Anyway here is the best that I can explain it:

About a month ago, the device started operating quite strangely when I was going through the file list to select a video file in my movie folder. The selection cursor continues to move over the file list, over rows, columns and even over to the next pages rapidly without stopping…!? The remote commander intervention does not seem to interrupt this random behaviour, and system eventually settles down after several loops highlighting a random file. Once settled, the moment I start moving the cursor to any direction to select a file, the cursor starts running away like crazy out of control.

This is so frustrating. It’s like playing a video game trying heat a moving target. I have resorted to using the arrow keys on the remote commander to interrupt the loop to stop the cursor, but it is still a “heat and miss” to select the desired file. Can you now see how weird this is…?

I get all kinds of odd random behavior from the two boxes I’ve had. Never seen exactly what you describe, but I would suggest your only option is to do a power reset. Pull the power plug and let it sit for at least five minutes.Failing that, you can try a “reset box” from the settings menu. It will wipe any of your preferences, but basically puts it back to the “new from the store” state.

I have done several “hard re-sets” via the reset button, “soft re-sets” through the Settings menu, unplug & reconnect the main and even deleted the wd_tv file/folder on my drives, but to no joy…!

Thanks for your thoughts on this anyway.

sounds like a dodgy remote or interference maybe ?

when it starts going crazy and moving around by itself … take the batteries out of the remote and see what happens (if it stops…then you know it’s the remote)

also, maybe try a USB Keyboard to control the WDTV and see what happens

1 Like

Hi JoeySmyth,
I don’t think that the remote is the cause of this as I have removed and replaced new batteries in the remote and even tried another remote that came with an older version of WD HDTV media player with the same results…! You mentioned to attach a keyboard to the WD device. I didn’t know that this was an option…!
So, is it possible to attach a Bluetooth dongle to the front USB port and use a wireless keyboard…?

Thanks again for your advice.

You can try a Wired or Wireless Keyboard … i’ve tried both and they do work

BUT … not all are supported (i have a bunch of keyboards some work with the WDTV and some don’t … trial and error)

Failing that … there’s another option, the WDTV Remote App (haven’t tried it in ages though … so dunno if it still works)

https://play.google.com/store/apps/details?id=com.wdc.wdremote

1 Like

We need new firmware for WD TV to fix some crash and for Netflix here in Italy !
Why WD don’t release a new firmware ???

what are talking about ?
this is the 2014 WDTV Media Player Forum … this device does not support Netflix

And if WD stopped supporting Netflix on this “latest” device, most probably means they’re not supporting / updating the older devices either.

I refer to Paskal’s mail in 2016. . Can anybody please help me . I have the same picture on my 2014 WDTV and cannot access any other info… its seems its not as simple as the replies.
Would highly appreciate some help.
I am in South Africa and WD only talk to Canada and USA on their chat line