New EX4100 Cloud Access Disabled after update to OS 5

Just bought a new EX4100. Was setting it up today and decided to upgrade to the latest firmware version 5.10.122. Now the Cloud Access is Disabled and I am unable to create a Cloud Account for OS 5. It just says Updating… and eventually times out. I’ve tried

*Rebooting the router
*Rebooting the MyCloud EX4100 device
*Pressing the 4 second reset button

Please advise. Looking at the logs it said the firmware update failed but it says I’m on the latest version in the dashboard.

The Network Link is a warning message that probably got triggered on boot and can be cleared in the AdminUI. The following article explains how to add users and enable cloud access is OS 5.

29448 My Cloud OS 5: How to Add Users and Enable Remote Access

When I try to create a new cloud account, it get’s stuck on “Updating…” after I click OK. After about 10 minutes it timesout and logs out of the AdminUI.

So I did a Full factory restore. During the initial set up it asks me to create a cloud account, but I get the same result. Stuck on this Updating message and then it logs me out after 5-10 minutes.


Also when I click on check for Firmware Updates it gives me this error.