New EX2 Ultra-can't get into web panel, poor experience

I just purchased an EX2 Ultra (after just buying an EX which I will return) and my experience so far is not very good.

  • I am on Mac OS X (10.11.3)
  • The login fields are blank, no password has been set and I get an error that the username or password is incorrect.
  • I cannot get into the web panel on the EX2 Ultra.
  • I downloaded every app that may get me access to the unit and I managed to update the firmware. Still can’t get in.
  • I’ve reset the unit. Still can’t get in.
  • I’ve seen online an image of an icon of an actual WD My Cloud EX2 Ultra Setup desktop application. I can’ find it anywhere.
  • I tried using my WD My Cloud EX2 Setup application to setup the Ultra - it doesn’t even see the Ultra on the network.
  • I am trying to copy the contents of my also new EX2 to the the EX2 Ultra so I can return the EX2. The speeds are treacherously slow over gigabit ethernet (through the whole pipeline) and I don’t understand why - approx. 4 Days for 1.75 TB.
  • The fan noise on the EX2 Ultra is significantly louder than the EX2.

Any ideas folks?

I just bought one of these. It works great. What I do whenever I have to login to something plugged into my network is log into my router & get the ip of the device. Then I login using the actual ip of the device with a browser. I never use bundled search software.

I’ve had a great experience with the Ultra. Transfers to the Ultra from another new MyCloud device run around 60 MBps. (multiple file types) Normal transfers from Windows to it run between 60MBps to 90MBps, depending on file types.

I had bought an EX2 last year & had to return it. It was painfully slow.

I tried using the IP address and the .local address. It doesn’t matter. I can’t get into this thing. And where’s the EX2 Ultra desktop app.? I can’t find that anywhere?

I would try WD Access for Mac.

Also try WD My Cloud Desktop App

Also, make sure that your router is not set to block new devices.

Could also be a setting on the mac itself.

Could try connecting with a tablet too. I can use Chrome on my iPad to login to the dashboard & change settings.

It sounds like it’s a router issue to me without knowing more. What kind of router are you using?

Folks I called Western Digital and here’s the point by point solution that got me into the EX2 Ultra dashboard and a few other bits of information.

I was instructed to do a different reset than what I originally did (pressing reset button while the unit is on for 5-6 seconds) and it goes as follows:

Getting to the Dashboard

  • Unplug the ethernet cable and the power.
  • Press the reset button
  • Plugin in the the power while still pressing the reset button (do not stop pressing)
  • Keep pressing the reset button for 45 seconds, then let go.
  • Plug in the ethernet port.
  • Go to the IP address of the unit
  • Proceed according to prompts.

Now for me, when I first opened it from the box and when to the IP I never got the prompts for setting it up. Following the above instructions I did without issue and its up and running.

Dealing with the crazy slow transfer between the EX2 and the EX2 Ultra (even though I have a fully open gigabit ethernet pipeline.

I was instructed by the same rep to use the web interface to move files rather than using the Finder (aka desktop) on my Mac. For the record when I started doing this through the Finder, it said it would take approximately four days to copy 1.75TB. ABSURD. Now that I am using the web interface which I started about 3 hours ago, it’s already at 20% copied.

Disclaimer: to do this was cumbersome and I wouldn’t want to work this way. In order to copy files from one NAS to the other (both being variants of the EX2) I had to set up each unit as a remote server with a password, create a job in the remote backups section of the Backups panel of the Dashboard, type in the destination IP (local on the LAN) in the EX2 so it’d know how to see the EX2 Ultra, choose a source folder and choose a destination.

Yikes! All I wanted to do was copy folders from one NAS to another. Can’t believe I had to go through all of this just to copy files and get the full speed benefits. Why the Finder is making thing so slow, I couldn’t tell you, but I sure don’t have that problem between to Macs copying files over gigabit ethernet. It’s blazing fast. Maybe it’s the difference in file structure or drive formatting - I don’t know.

Aside from that I was told that the desktop applications have been discontinued even though their still on the support website downloads. I was told it’s better to use the web panel. This came about because I saw an icon on a site with an actual WD EX2 Ultra desktop app for the Mac. Different than the one I have for the EX2; which never acknowledged my EX2 Ultra on the network so I thought I had to have this mysterious EX2 Ultra app that is nowhere to be found on the WD site.

If there’s an easier way to just copy files I’d love to know it, but al least things are going now.

I hope this helps you all.

Glad you got it fixed. Good to know that a basic router type reset works on the device.