New 2TB My Passport is seen in the Devices & Printers, but not Disk Manger - Solved

Hi, I purchased a new 2 TB My Passport portable drive and it was recognize by my laptop, but no drive letter and can’t access it. Under devices & Printers, drive was showing it had a problem… It also was under the "safely remove device in the task bar. When I installed the the WD device driver, the drive showed up in the in the devices & printers as having no problems, but still no drive letter. Also, doesn’t show up in Disk Manager and I can’t assign a new drive letter. I think it’s showing as a unknown device in the Device Manager.

My 1TB My Passport portable drive that I purchased January 2017. Used it for backing up my computer with Norton Ghost 11. Checked it the other day and it is doing the same. I could only get into that one by booting into Norton Ghost while the drive was still plugged in.

I have a older 2 TB My Passport portable drive, I have mapped as drive M, and it works great, is shown as a healthy drive and works in all ports. All my USB flash drives work in all the ports.

I tried to update drivers, windows said it couldn’t find drivers online. Also, when I first plugged in the new My Passport, windows looked for a device driver and noted that the drive couldn’t by downloaded.

I have never dropped any of these drives and my computer works great except for this problem.

Specs
Laptop purchased in 2010 is a Samsung R580, Intel Core i3 330M @ 2.13GHz Arrandale 32nm Technology, 8.00GB Dual-Channel DDR3 @ 532MHz (7-7-7-20), HD Western Digital WDC WD5000BEVT-35A0RT0 (SATA), Motherboard SAMSUNG ELECTRONICS CO. LTD. R580/R590 - no version number given, Windows 7 Home Premium 64-bit SP1.

New My Passport model WDBYFT
Old My Passport model WDBY8L

I have tried all the solutions I could find on this site and nothing worked. I’m thinking maybe MB chiipsets or not finding Storage Server under system services. If you need more information, just ask. I’m a old gal and everything I have learned about computers is from the internet, DSLReports.:wink::wink: I take really take care of my electronics.

All help will be greatly appreciated and I will learn something new. Now I’m going to sleep as I been up over 24 hours working on this problem.:sleeping: Thank you.

Hi MissJackorama,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support if you are having trouble with the form.

Mark this as solved.

Every time I plugged in the WD my passports and windows would look for the drivers. Then an error that windows could not find drivers for this device. This also happened with my Bluetooth and ended up using a BT transmitter. My conclusion, Microsoft is not supporting device drivers anymore to windows 7 users. Solution was to move to windows 10 and all the WD my passports work without me having to install anything extra. Also, got my Bluetooth back.

Solution was updating to windows 10, and it is a lot better than when it first came out. You can try other OS if you don’t like windows.