WD My passport (TB) sometimes visible / sometimes not

For two years i have been working with My Passport (2TB) without any glitch. Now it just doesn’t show up in the Windows explorer (WIN 10) anymore.
The connection cable is OK, I tested with a different USB 3.0 device, the white light is on (steady!) and I feel the hard disk working. I cannot access the Passport.

But then, suddenly, after let’s say 10 or 15 attempts, the Passport shows up, all files are there - but just for a minute or two then it disappears again - no external hard drive (F:, in my case) is visible.
What went wrong, what can I do?
I just want to copy all the files to a new Passport in order to keep them.

Hi, you mentioned that you tried a different cable, but have you tried a different computer? Does the passport makes weird noises?

Yes - I tried it in different PCs, Notebooks with different cables. Always
the same.
No strange noises, just the regular little humming as always.
It never fell down.


I have the same problem and the serial number is half gone already. it comes up in printers and devices but cannot be opened. its been a little over a year now.