Yet another WD My Passport not showing up

This happened a few days ago. Since then my passport worked fine.

  • When i plug the HDD the light flashes three or four seconds and then stays solid
  • The disk doesn’t makes the classic beeping or clicking sounds, but doesn’t sound just right (I recorded a video: https://imgur.com/hOqVxNO)
  • Windows “makes” the sound when i plug or unplug the disk and the devices shows on “Safely remove devices” list. (Sorry if the name is not exactly correct, english is not my native language).
  • The disk doesn’t show on disk management
  • I Tried to reinstall the driver in devices management. The disk appears with the yellow mark and when i tried to see what’s the message, says that the device couldn’t initiate (Code 10)
  • I tried to access it through WD Drive Utilites and Data LifeGuard Diagnostics. It doesn’t appear there also.
  • I tried to see if the disk appeared in diskpart.exe, but doesn’t
  • Obviously I tried all USB ports of my laptop and also tried in another laptop with same results.

Anything else that I could try?

Thanks in advance

Hey @afertitta ! did u find any solution for your problem…
Waiting for your reply :slight_smile:

Hey! unfortunately, no. Sorry!

@afertitta well thanks for the reply :slightly_smiling_face: