Network sharing doesn't´t work with W7, am I correct?

My questions are:

Shared folders on WIndows 7 will not be seen in Network Sharing on WD TV Hub?
Yes or No

Only if the folders are added to Public/Media Shared folders, with enabled Media Server option and only files that are shared will be W7 defined media files (no mkv), and accessible by selecting Media Server for the source?
Yes or No

Your questions require double negatives for answers. :slight_smile:

The WDTVs work fine on Win7 with ordinary network shares.

Your second statement is not true, either.

Well… Since i have the Live Hub my Shared folders could just been seen fine on my Live Hub.

But yesterday i bought 2 new harddrives because i need the space, just switched them with the old harddrives and shared them as usually, but the hubs, i have 2, can’t see any folders now. My sharing settings are the same as always and whatever i try, the hubs don’t see the folders/disks. After switching back to th old disks… the same, no folders.

So, now i installed a fresh version of Windows 7 Ultimate 64, applied the sharing settings that are needed, and still no luck. With the old or new disks. But if i share every folder that’s on the disk seperatly the hubs can see them just fine and plays them all.

But that’s fine for now, but what am i missing / doing wrong? I want the hubs to see my Disks, not every folder seperatly on the disks. :cry:

It may have to do with how the shares are named…  The WD’s have a bad habit of ignoring certain names if they have certain characters in them.

It´s just Media and Downloads, no other characters.

I have same problem like Battlestar
W7 64 Professional edition
WD doesn´t see my folders

and its not name of the folders becouse I have changed the few times to check is it name problem

@ TonyPh12345
The WDTVs work fine on Win7 with ordinary network shares.

What do you mean by ordinary network shares?

Plain, vanilla shared folders.   No need to use Homegroups (they aren’t supported anyway), add them to any type of Media Library, etc.  

I seem to have a problem simular, but it only occurs with one of my drives.  I have an older(<1) WD My Book 1.5TB drive that will not show up in network shares.  All other three WD HD’s I have on the network are fine.  I have to use a third party media server to share the My Book drive across my network. 

Any Ideas?

Can anyone post Homegroup settings and Advanced Sharing Settings for Windows 7
that allows you to share folder from PC with WD TV Hub?

I posted like two posts up that HOMEGROUPs are NOT supported.    That is a Windows 7 proprietary technology.

For STANDARD shares, the only settings required are:

Turn ON network discovery.

Turn ON File & Printer sharing.

Use USER accounts and passwords to connect to other computers.

1 Like

I never used User accounts and Passwords. I used to go by this guide:

  1. Press start menu and go to your Control Panel.
  2. Open your Network and Sharing Center.
  3. Click on the right on Change advanced sharing settings.
  4. Press the arrow at the right to hide your Home or Work profile.
  5. Then Press the arrow at the right to show your Public profile.
  6. Make the following changes:
  • Turn on network discovery.
  • Turn on file and printer sharing.
  • Turn off Public folder sharing.
  • Turn off password protected sharing.

After these settings let’s take a look at your shared folder:

  1. Go to the folder you would like to share.

  2. Right click on the folder and select properties.

  3. Go to the tab ‘Sharing’.

  4. Press the button ‘Advanced Sharing’.

  5. Check the checkbox ‘Share this folder’.

  6. Now press the button ‘Permissions’.

  7. Click on the user ‘Everyone’, Give the ‘Everyone’ user at least permission to read this folder.

  8. If the user is not there please proceed to add the ‘Everyone’ user, if the user is there you can skip the following steps 1 to 7.

    1. Press the ‘Add’ button.
    2. Press the ‘Advanced…’ button.
    3. Press the ‘Find Now’ button.
    4. Select the ‘Everyone’ user from the appearing list. 
    5. Press ‘OK’ and in the next screen press ‘OK’ again.
    6. Give the ‘Everyone’ user at least permission to read this folder.
    7. You can now save all settings and close all windows.
1 Like