Network access to Mycloud Home

Hello everyone !

I used to have a MyCloud device which was working just fine, but due to the incompatibilty with OS5, I had to change to a MyCloud Home.
With my previous device, I was able to scan my documents from a network scanner, and directly save the file on MyCloud. The scanner just needs the network address of the folder, which use to be something like IP adress\username\folder.
With MyCloud Home, I try to do the same, but it won’t work. I know the IP adress of the drive, but it looks like there is a hidden architecture between the root of the drive, and my personal folder.
Has anyone any idea on how to proceed ?

Many thanks in advance for your help !

Maxime

Hi @Maxouche,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Hi @Keerti_01 !
Thanks for your reply. I actualy opened a ticket wth the support (with reference 220203-003430).
No reply so far, although the confirmation email mentions a reply within 2 business days.
Appreciate if you can follow up.
Kind regards,
Maxime

It is unlikely that you will be able to use the MCH (My Cloud Home) as the destination server using the existing software on the network scanner. The scanner is likely to only support SMB1 and MCH can negotiate as a SMB server up to a 3.11 dialet and will not work with a SMB1 client. There is no setting on the the MCH to change that as none of the firmware for MCH has ever been able to do it and unlikely to in the future because SMB1 has been deprecated.

Upgrade the scanner or the MCH or use a different destination.

Thanks NoPlex for your reply.

Actually, I think my issue is simpler that that. I made a screen copy of the configuration interface. My issue is what to mention in the “Network Folder Path” field.


With my previous MyCloud, I entered there the adress IP/User folder/scan folder, User Folder being my main folder on my MyCloud device. But with MCH, if I do the same, it will not work (the same way as it is impossible to manually map a network drive).
Thanks in advance for your further advice.
Maxime

Since a reader has no way of guessing what document scanner you are running, there is no way of knowing if the scanner can independently access the network drive (MCH here) without the aid of a scanning app on your OS such as Win10. The scenario described above is for such as case where the scanner has to negotiate a SMB dialet with the MCH.

If you are saying you have no way of accessing the MCH by local LAN normally then you may have a network problem with the MCH. Try to exit WD Discovery from the tray icon and restart it, then see if you can map the Public LAN through the File Explorer and pin it to ‘favorite’ or ‘quick access’. You can do that by entering something like:
\\Mycloud-012345\ in the File Explorer address bar
where 012345 is the last 6 digits of the MCH serial number/character.

From there, if you do see the two network accessible folders, you can map the \Public folder in Win10 (by right click on folderand choose map) for example, to a drive letter such as P:
It may now be easier to assign the drive P: as the scanner destination.

I have/had a similar problem: I couldn’t directly access my share without going through WD Discovery. Found a workround using Siber System’s Goodsync:


Annoyingly, when I login to WD Discovery desktop app, it creates my share on another instance of (mycomputername)

I too was directed by WD towards the MyCloud Home as support for fantastic OS3 based MyCloud is ending.

I was given two options for the 20% discount (in Australia), the MyCloud Home or Duo.

Just worked out that it seems to work very differently (eg no dashboard).

Like NoPlex above, I would readily move files, open edit and save Word/excel etc simply on a network drive.

I just moved 800Gb from old My Cloud to new MyCloud Home in windows explorer using the 192.168.0.11 ip address reported by IpScanner.

But cannot see the files anywhere through the desktop/web access

I haven’t given up yet, but not liking the sound of this

PS
windows explorer showed a folder named Public, so I put files in there but ???

Public folder will be accessible by all. you should see your share drive (after logging in) as a duplicate computer name in the left hand folder tree…
image

Thanks for reply Allend66.

I am not seeing the same.
I get a Zdrive mapping in windows explorer which is different for separate login I use - I assume this is the private folder for each login (tested this by loading files under one, which are not visible under different logins.
image

However I do not get any Public (nor TimeMachine) folder (I am on Windows 10)

I have shared a folder which is only visible via web access (and in the shared folder not in the files folder). This is not visible in Discovery/Windows Explorer.

I can access the public folder if I enter the IP address into Windows Explorer eg
image

and this is unaffected by differing logins in WD discovery/web access.

It is also not visible in any login nor web access

Seems like there are several separate file mgt systems.

Also, seems like the WD Discovery/web access not only doesn’t see/display the files copied into Public (via IP address) it doesn’t count them in remaining/used storage

Hope this all makes sense, and that someone can enlighten me on best way to use this thing.

Some improvement.

I put \MyCloud-VRxxxxx into windows explorer and it found the Public and timeMachine folders (same as putting the IP address)
I got the VRxxxxx from IPScanner that also gave me the IP address (Note to self - I need to make it a static IP address)

I have pinned this in Explorer so now have
image
(of course with more characters) and it is now visible under Network
The first is the OS3

I thought the 2nd would be the “MyCloud-last 6 digits of serial No” but it isn’t.
It is 8 Alpha characters - given by the IP Scanner and it works

Have you had a chance to look at the Knowledge Base? It updated most everything that is missing from the dated (2017) user manual.
https://support-en.wd.com/app/answers/detail/a_id/3009

Hi Everyone !

many thanks for your inputs here, and sorry for my late reply, as I’ve been quite busy lately.
However, I tried everything, and it didn’t work, until I found that I have no “Public” folder, which may be the reason why I see nothing under “network”, or by trying to insert the address “Mycloud-XXXXX”.

So I guess that my problem now is to know how to create this “public” folder. I would appreciate any tips !

Maxime

My Cloud Home users, especially owners of the older, slower and less secured but more versatile ‘My Cloud’ are always trying to do a lot of network storage functions expected of a traditional NAS and being disappointed. WDC has tried to warn users that:

IMPORTANT\ 35pxx45px Important:

The My Cloud Home Public Share is designed and implemented for Windows File Backup. It is not designed for local LAN storage access. Although is can be accessed on Windows and macOS, it was not designed to be used as local LAN storage. Please use WD Discovery and the User Private Space for your My Cloud Home content storage needs.

Since you are trying to use a Brother business scanner using unknown network protocol to store data to the My Cloud Home, it may or may not work in a business network with many (>5) concurrent users. No one knows what you have tried or not tried and probably not too many users here have your model of Brother AIO so your best course of action is still to contact Brothers or WD technical support directly as suggested above.

It doesn’t hurt to spend a few minutes reading about the change from MC to MCH from someone who knows about the other choices available:

Greetings,

Thank you for the infos here.
I have a serious problem using WD Discovery, Windows 10. It simply freezes Explorer, speed 0 bytes/s, etc.

I have found, thanks to you the way to quick and efficient access to the drive via IP address.

I would like to NOT use the (…) WD Discovery almost impossible to make work.
Shall I move my data from Z drive (WD Discovery) to the Public Share to be able to use the drive normally as NAS one?

Thank you in advance for any piece of advice.

There is nothing stopping a user from using the Public SMB Lan space for storage, but the two space shown above are not equivalent and you won’t be able to share Public LAN space with remote users and devices. If you are fine with the many limitations you can go ahead and disable WD Discovery by right click on the WD tray icon and ‘Quit’. However, you have already have successfully filled up 50% of the MCH space using mostly the kddfs supported by WD Discovery, it would make more sense to see if you can find your way back to a working WDD by re-installation or troubleshoot the reason(s) it is malfunctioning. Please follow the link below and create a support case.

  • Local Area Network Share (LAN)

Content added to the Local Area Network Shares (Public and TimeMachineBackup) cannot be accessed or seen using the:

  • MyCloud.com - Web App
  • My Cloud Home - Mobile App for Android or iOS
  • WD Discovery - MyCloud.com Login Desktop App