Need help with WD Smartware

Hello there,

First of all thanks for reading my topic.

A few things I want to clarify;

  • I am no noob on computer hardware and software area, So I do have a general clue of what I’m doing. :slight_smile:

Okay so I bought my WD my book essential the other day, and the drive itself works fine, it’s fast, It gets recognized by windows etc so no problems there.

But… I can’t get the WD smartware to work. It just refuses to work. I can install it, but I can’t run the ‘WD smartware’ Icon in the folder (‘Application not started from drive’) If I run it directly from my C:\ folder it does open, I can acess home and Help, but Backup, Retrieve and Settings are greyed out and inacessible. The WD drive DOES NOT show in the ‘Home’ screen, just a collection of all my Drives/Partitions (the WD drive is in that list)

so I’ve tried reformatting the drive : no avail, same problems

I tried re-downloading the software : Same problems

I’m at a loss here. I run Windows 7 Ultimate on a x64 system.

I bought this drive because of the software (Seemed very neat) and I heard positive praise everywhere about how easy it was to use. Now I have no problems with a little bit of troubleshooting, but this is a nut I can’t seem to crack on my own.

So who can help me out here? Help would REALLY be appreciated.


Hi, once you install smartware click on start and then all programs to open it from there. When you say “The WD drive DOES NOT show in the ‘Home’ screen, just a collection of all my Drives/Partitions (the WD drive is in that list)”, what do you mean? On the Home tab there should be two columns, the one on the left that represents the computer and the one on the right that represent the my book. On the latest smartware version you need to click on the my book icon on top of the right column to make the backup and retrieve tabs available.

I mean that I just see one colum. There is no second colum for the WD drive, but the drive DOES show up in the left colum together with all my other hard-drives. I don’t even see the my book icon.

that’s what I see.

Well in that case you might need to update smartware to the latest version. Check if that works.

Hi Rhendera,

I was wondering if your problem has been fixed yet? I am having the same problem as well and I could not update the SmartWare. It just shows that the SmartWare is installed unsuccessful due to Error Code: 1605. Could anyone fix this problem for me? Your help would be much appreciated. Thank you! :slight_smile:



@ Angela_Lee

Check if the link below helps to uninstall smartware. After you uninstall it try installing it again.

1 Like