My Book Essential 2T that I just purchased and installed does not appear in WDSmartWare Home Tab now

My MyBook Essential 2T that I just installed on my Windows 7 computer does not show up in the Home tab of WDSmartWare.

It does appear in My Computer and Windows Explorer, and I can see all the files there, including the ones that got backed up.

This just started since upgrading the WD SmartWare software to version And that updating process took many attempts, including having to remove the Security from the My Book. And I have no idea if it’s properly installed. It did not happen the way a person would expect software to install.

I’ll say that this software seems to be very familiar to the problems I had with a HP 500 GB Backup product like this. I finally abandoned that External Drive because of a lack of support, and the software did not work as expected.

I would be very disappointed if this My Book Essential is going to be plagued with the same software problems.

I have read some of the other posts about the drive being not recognized by My Computer, but that isn’t my problem. The WDSoftare is not showing it.

Hi, try uninstalling Smartware from your computer and then install the last version again.


Thanks for the tip. I’ve been in contact with WD support about the problem I’m having. So far their suggestions haven’t worked. But they didn’t suggest deleting the old SmartWare from my computer either.

Your suggestion does sound like a good one, and I will keep it in mind if WD support fails to resolve the issue I’m having.

There is definitely a problem with the version updating procedure on my computer. It doesn’t work, and now the My Book is showing which came with the unit originally.

I would never recommend anyone buy this WD product.

I think I’m having the same kind of problems I did with a HP My Book, and it’s crappy backup software. If I’d have known that it was the same software I would never have purchased the WD My Book.



Actually I would like to buy my book essential 2Tb, can I just use the harddisk just to store my data without install the smartware?because, i don’t need any back up, i’m just use it to store my datas, movies, etc…

and because I see a lot of people saying about the smartware problem…


best regards,

I’m not sure if you’re offeroing to buy my My Book, but I’m probably going to keep mine for just the purpose you mention.

Even though the SmartWare software seems to be **bleep**, and I’m still waiting for WD’s next suggestion, I will just reformat the drive, and use it for my own backups, and file storage.

Yes you can use it without installing Smartware. Don’t bother with the firmware update either.


Just thought I’d add an update to my problem.

I was contactd by Western Digital level 2 Support, by phone, and they did an online session where they took control of my computer, then resolved the problem I was having, and  upgraded the Smartware to version

The My Book Essential 2T is now operating exactly as it should, and so is the SmartWare upgrade.

I’m back to being a happy camper.

I would be careful - I did that with my brandnew 2TB MyBook Essential and stowed 300Gig of critical data on it.  It  has disappeared several times since then.  Now it shows up as a listed USB device but not under My Computer - regardless if I use this borrowed laptop running XP, or my own Vista 32-bit system.  I just bought the thing less than 2 weeks ago!  Ihave spent all week trying to get it working.  I have tried various diagnostics including testdosk and the drive is there as W:// which I assigned it.  This is abominable.  My other staorge drive works fine.  Did you change manufacturing factories?  I work for aradio station and i’m **bleep** tempted to do an impromptu review. :frowning: But i would settle for some solid advice just making the drive work again.