Help needed (smartware)

a few months back I opened another topic, sadly I never really got a solution for my problem.

The main reason why I bought the My Book at the time is because the software seemed ideal for me. However, right out of the box, my smartware refused to work. 

When I try to run the files on the HDD:

  • I run WD Smartware.exe

  • I get the error “application not started from drive”

I tried a few more things, got the WD software installed, but it failed to recognize the My Book. (Couldn’t make back-ups, almost all the tabs were greyed out) 

at this point I made a topic here:

I did not manage to fix the problem, I tried reformatting the drive, putting the files on again, followed all the tutorials on the website telling me how to (and I’m no stranger to computer Hardware and Software!) 

at that point I decided to plainly give up and to just manually back-up to the drive, but it keeps nagging at me. 

now, a few months later, I’m willing to try again. 

I just formatted my drive again, followed these exact steps:

and I get the same error again! “application not started from drive” 

I uninstalled all WD smartware software from my computer, ran a registry scan so all the files would actually be off of my computer, restarted and I got the message. 

I run Windows 7 x64 

I do have more than one HDD in my computer - one 2 TB HDD, one 250GB HDD and a 120GB SSD. I have five partitions (C :,D :,E :,F :,G: ) and My Book (J: ) - I suspect the problem is due to my many paritions.

any help would be greatly appreciated. I don’t know what to do anymore. 



Oh and another small bit of information - running the update from this website results in an error and a force close.

37 views and no one has a solution? =(

What is the model number of your My Book drive? I read your old post an saw the screen shot, SmartWare is recognizing the drive as a source but not as a backup destination, there is a chance that your My Book might be an earlier version, not compatible with SmartWare.