Need help with Joomla install

I am stuck with the Joomla install because I do not know the mysql password running on my EX2.

I tried the userid/password (admin/admin) mentioned in this post ( http://community.wd.com/t5/WD-My-Cloud-EX2/mySQL-on-EX2/m-p/695358#M30 ) by WDTony but that didn’t work - just as I expected since mysql is running under user root. I also tried (root/admin) for userid/password and that didn’t work either. I really cannot proceed without knowing the password. Any WD staff has any idea on the mysql login info? Anyone else got Joomla to work on their EX2 or EX4 or Mirror?

Here’s screenshot showing that mysql is running under user root (until mods approve the image you can see it here -> http://imgur.com/JHORUzq ):

And a screenshot of the Joomla config screen where I am stuck  (until mods approve the image you can see it here ->  http://imgur.com/MKsxodA ):

1 Like

It turns out that the mysql db password is actually same as my SSH password. I never thought of that before. But after trying that, it worked and my install completed successfully.

BUT - now I am facing one issue that I thought I could simply solve by doing port frwarding but it does not seem to be working no matter what I try.

I am able to access Joomla fine on my local network - BUT I cannot access it from outside the network. I get 403 Forbidden error. That indicates that it I am reaching the web server but for some reason I cannot view the pages, which are by default set to be visible to public. I looked through several different ideas by searching on Google for Joomla and lighttpd web server issues - and cannot find a solution.

Anyone have any ideas on how to resolve Joomla’s 403 Forbidden issue (might really be a lighttpd issue)? And yes, I have forwarded port 80…I am obviously reaching the web server since I am getting 403 Forbidden error. Just not sure what is causing it to block access from outside.

The URL I am trying from outside is: http:///Joomla but when I try from inside, this URL http:///Joomla, it works.

If this post helps resolve your issue, please give me a kudo by clicking the star under my username on the left. Thanks.

Solution to the web access from outside was very simple. Just had to turn on Dashboard Cloud Access from the dashboard’s General Settings. After turning that On, Joomla is perfectly accessible from the Internet. See setting pointed by red arrow in the pic below:

If this post helps resolve your issue, please give me a kudo by clicking the star under my username on the left. Thanks.

One last useful tip for any potential Joomla installers for EX2/EX4/Mirror.

Joomla by default allows to upload content files upto 10 MB in size. But you can change that from Site Administrator -> Media Manager -> Options. I bumped it to 150 MB, just so that I could upload a few PDFs that were 25-35 MB in size. However, during my testing I found out that I could not even upload a 9MB PDF but was able to upload a 5MB PDF. I remembered this post of mine about how PHP was only allocated a ridiculous 8MB in WD’s firmware -> http://community.wd.com/t5/WD-My-Cloud-EX2/Wordpress-Fatal-error/m-p/727266#M384  

So on a hunch, I changed PHP’s memory size to 200 MB in /etc/php/php-fpm.conf and killed php-fpm processes (see detailed steps here though this person only bumped it to 64MB but you can choose a higher vaue if you like but remember EX2 only has total 512 MB so don’t go overboard ->  http://community.wd.com/t5/WD-My-Cloud-EX2/Wordpress-Fatal-error/m-p/774767#M895 ). And right away I was able to upload a 30MB PDF - which I then shared as a http URL with a friend.

So Joomla can be another way to share files with friends as long as you know your external IP address or setup a dynamic DNS address and then tack the rest of the URL to it (like http:///Joomla/images/… ). Though not an ideal way to share thousands of files - but for a handful files, Joomla offers a way to share files via http URLs accessible from anywhere.

If this post helps resolve your issue, please give me a kudo by clicking the star under my username on the left. Thanks.

I’m amazed at you adding this application to the WD My Cloud EX2. Still, extreme caution is recommended.

Regards,

For anyone interested, you can upgrade your Joomla to the latest version of 2.5 branch - and it is recommended to do so to get the latest bug fixes and security patches.

When you install Joomla from EX2’s dashboard it installs an out-of-date version - version 2.5.6. But you can find the latest version from this page ->  http://joomlacode.org/gf/project/joomla/frs/ , which currently is 2.5.24 (for the 2.5 version). Follow these steps:

  • Look for the file link Joomla_2.5.x_to_2.5.24-Stable-Patch_Package.tar.gz (or if there is a newer verson look for the file that upgrades from 2.5.x to that version’s .tar.gz file).
  • Download that to your desktop and then ftp it over to /mnt/HD/HD_a2/Nas_Prog/Joomla/Joomla_2.5.6/tmp/ (or copy it to a share on the NAS and then move it to that location via SSH)
  • SSH into the server
  • cd /mnt/HD/HD_a2/Nas_Prog/Joomla/Joomla_2.5.6/tmp
  • tar -xzvf Joomla_2.5.x_to_2.5.24-Stable-Patch_Package.tar.gz (or if it’s a newer file then update the filename accordingly)
  • Once the files are extracted, login to Joomla Site Administrator from the browser
  • Go to Site -> Global Configuration -> Site -> Site Settings -> Site Offline -> set it to Yes -> click Save & Close
  • Go to Extension Manager -> Install -> Install From Directory -> enter  /mnt/HD/HD_a2/Nas_Prog/Joomla/Joomla_2.5.6/tmp into box for Install Directory
  • Click Install and wait
  • Once the install is complete, you will see a blue text saying install succeeded
  • Verify update by going to Site -> System Information -> System Information details -> Joomla! Version - this should now indicate the new upgraded version 2.5.24 Stable (or newer)
  • Go to Site -> Global Configuration -> Site -> Site Settings -> Site Offline -> set it to No -> click Save & Close

And you are done!

Trancer, why are you amazed?  This is a standard script that WD makes available for the EX2 right out of the box.  If there is any possibility that these scripts will cause the EX2 to lose data or become unusable then WD should say so and remove the fuctionality, otherwise they are exposing themselves to liability issues. 

Not at all. I meant to say I didn’t know this script was available for the EX2 and I was under the impression it was only for the EX4. Hence my surprise at the script running.

Regards,

Trancer - now I undersand your comment :slight_smile:

The app packages are also available for EX2 and Mirror.

1 Like

Just wanted to throw my two cents in here.  First off, I was unable to connect to the mysql database using the SSHD password. :cry:  However a quick search here revealed that in at least one version of the firmware the default username and password for the mysql server was “admin/admin”.  That worked for me and allowed mine to work properly.:smileyvery-happy:  The second thing I would add here is you can access your Joomla site securely (HTTPS://YOUR IP/Joomla) by insuring that port 443 is being forwarded from your router’s WAN to the LAN IP of your EX2 / EX4 / Mirror device. 

Also, Kudos to Cybernut1 for his input here.

1 Like