Help getting Joomla to connect to MySQL (error message says Joomla could not connect to MySQL)

#1

(edit - shorted title, added question below)

I am trying to install/configure Joomla on a DL2100, following http://support.wdc.com/KnowledgeBase/answer.aspx?ID=11039. I get an error on step 5 entering database configuration details saying: ‘Could not connect to the database. Connector returned number: Unable to connect to the Database: Could not connect to MySQL’ and the installer will not let me proceed. I think the username/password fields are not correct, I tried several combinations of different username/passwords but nothing has worked (root, admin, my ssh user name, etc). I SSH’ed to the machine to access MySQL from the command line, but MySQL commands fail because I am not sure what user/password to use. I then tried to reset the root MySQL password, but that didn’t seem to work either (see below, noting I am not proficient on Linux).

Can anyone help or provide suggestions on how to correct this error? What MySQL database user/password should I be using?

==========================

This is what I have done so far in more gory detail…

According to https://community.wdc.com/t/mysql-on-ex2/98147/3, the default username/password is admin/admin, but this doesn’t work.

I have been trying figure this out all day with no luck, but I am a newb at Linux and probably doing everything completely wrong. I SSH’d to the machine and tried to reset the MySQL password following http://dev.mysql.com/doc/refman/5.7/en/resetting-permissions.html. I find the PID with ‘ps’, I kill the MySQL process, create an init file to change the root password to ‘MyNewPass’, start MySQL with --init-file option to reset the password. I get an error (below) but I don’t think its important, the MySQL process starts, so I assume the password is changed. So I kill the process then restart it again normally, and verify the process is started. I then try to call MySQL with user=root, password=MyNewPass, but I still can’t access MySQL, doesn’t look like the new root password works. These are the commands I use.

# ps -ef | grep mysql
  (shows me the PID for mysqld)
# kill 4631
# ps -ef | grep mysql
  (confirm the process is killed)
# /bin/sh /usr/bin/mysqld_safe --init-file=/home/root/reset1 --datadir=/mnt/HD_a4/.@database@ --user=root &
  (gives me the following error)
 /usr/bin/mysqld_safe: line 316: my_print_defaults: not found
 /usr/bin/mysqld_safe: line 322: my_print_defaults: not found
 151029 18:04:11 mysqld_safe Logging to '/mnt/HD_a4/.@database@/mycloud.err'.
 151029 18:04:11 mysqld_safe Starting mysqld daemon with databases from /mnt/HD_a4/.@database@
# ps -ef | grep mysql
# kill XXXX
# /bin/sh /usr/bin/mysqld_safe --init-file=/home/root/reset2 --datadir=/mnt/HD_a4/.@database@ --user=root &
 (same messages as above)
# ps -ef | grep mysql
# kill XXXX
# /bin/sh /usr/bin/mysqld_safe --datadir=/mnt/HD_a4/.@database@ --user=root &
 (same messages as above)
# ps -ef | grep mysql
# mysql --user=root --password=MyNewPass mysql
 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Just in case it actually did work, I went back to the Joomla configuration webpage and tried to connect to the database again, but it still didn’t work, using the following settings:

database type: Mysql
username : root
password : MyNewPass
database name: user_database
table prefix: d5x41_ (randomly generated)

I rebooted and tried the entire process again, but it still didn’t work. I still can’t access MySQL from either SSH or from the Joomla configuration page, and the password reset for user ‘root’ doesn’t seem to have any effect.

At this point I have no idea what to do next, I can’t figure out how to log in to MySQL. Any advice or suggestions would greatly be appreciated.

#2

Hopefully an experienced User will be able to assist.

#3

i tried to install Joomla on yesterday and i had exactly the same problem…

what host?
What database?
What user?

i cant create any configuration, because i dont know what i should place on these fields.

#4

Same issues here with my EX4100. Any help with this?

#5

Any one have found a solution for this. I have tried admin/admin SSH passord and many other things.

#6

i abandoned it… i dont have time to fiqure out something that should be said when setting it up…

#7

Hi

I have same problem with my DL2100.

I dont know user/password to manage MySQL, including trought phpMyAdmin

Any suggestion?

Thanks in advance

#8

Did anyone find a solution?