Error Mysql/MariaDB root login reset to start with MySQL/MariaDB

Hi ,
I wanted to start with MariaDB and installed phpmyadmin via AppStore.
According WD I tried
‘root’ & PW: empty/`` via phpmyadmin App → not working
I tried to reset the root password with following command:
python3 /usr/bin/ -r using SSH .

The SSH console reports an error…at this point I do not know how to proceed/handle the message.
Any expert here, who can give me a hint what to do?


PS: The network database is set to ‘ON without remote access’

Thank you, but none of the proposed login/password combinations did work.

admin + empty
admin + admin

Why do you assume, that the combination given by WD

root + empty

is not the correct one?

I would assume, that I have to take care of the error message…


Ah ok,
Firmware of OS5 is

I tried to follow these hints

service mysqld status
Did not work

ps -ef | grep mysql
9911 root 2848 S grep mysql

Does the last one mean, that the mysql server is running?


That looks difficult. And the explanation is not very good. Imo
If I can get it running without this 3rd party installation , I would prefer.
I do not think, that my skills are good enough to be safe from any critical issues by using this WD how-to.

Why did you even delete the Link?
Too critical?
Or can I repost?

Ok, I just saw, that you deleted because you are upset.
The link recommended was
How to Install 3rd Party Apps on My Cloud OS 5

I will finally wait for an answer from WD Support and if that does not help try to follow the 3rd party app installation guide.

And @Cerberus , I won’t need luck.

Guten Rutsch

Ähh Yes…it is.

But thanks anyway.

OK, I think I was wrong - you are right at this point:
My Cloud OS 5: Download and Install 3rd Party Apps Manually

Here it is.

OK, here is the final solution.

The database was corrupted and the WD Support recommended to remove the MySQL Database .

  1. Save your data (just a recommendation from my side…I waited and did buy an external HDD…what I always wanted , because it is strongly recommended)

2.Login via SSH as root on the Device
How to Access WD My Cloud Using SSH (Secure Shell)

  1. Remove the Database with SSH command:
    rm -rf /mnt/HD_a4/.@database@/*

  2. Switch the Network Database OFF and ON.

(I personally deinstallled phpmyadmin before I started.)
After reinstallation of PHPMYADMIN I could log in.

Note from WD Support:
MariaDB is not a supported 3rd party app on OS5 /what I thought it was…
So I will proceed with the native MySQL Server , which is up now.

Thanks to all , who provided hints for me.
Here and especially on Github.

Lions Go,