NAS to USB backup repeatedly failing with error "Backup failed. Please check your system settings"

I’m beginning to lose my patience with the My Cloud Mirror.

WIth the sudden catastrophic failure of one of the 4TB drives (despite the Dashboard saying the drive was “healthy”) in my My Cloud Mirror, I picked up a 6TB WD Elements in order to make a complete local backup, but the backup repeatedly fails.

I ran the backup over night and, this morning merely had the error “Backup failed. Please check your system settings”. I checked the system logs and saw that some time over the course of the night, the My Cloud changed it’s date and time; because of that, I turned off the NTP Service, cleared the system logs, and ran the backup again. It has twice now failed with the same generic error message, but this time without anything showing in the system logs.

The backup job is straight forward, so I’m not sure what is causing the failure.

Anyone have any advice as to how to sort out where things are failing? At this point, I just want to make a complete local backup so that I can purchase a new NAS and be done with the My Cloud; I’ve barely had it a year, and it’s twice now completely failed.

Job Name: Backup
Direction: NAS to USB
Source Folder:
CX61
Downloads
Movies
Music
Public
TV
Torrent
Videos
SmartWare
TimeMachineBackup
Destination Folder: Elements_25A3-1
Backup Type: Copy
Auto Start When Connected: OFF

UPDATE: The failure seems to be happening when copying over the “Music” folder, but nothing shows in the system logs as to what the issue may be.

UPDATE: I ran each folder as an individual backup job, and each ran fine with the exception of the Music folder. When backing up the Music folder in “copy” mode, it failed about half way through; when backing up in “synchronize” mode, it made it all the way to the end, giving me hope, but then also showed that it failed. In both cases, nothing showed in the system logs.

Hi OriginalGabriel,

It happens when My Cloud rsync times out as the My Cloud rsync TimeOut is set to 60 seconds and cannot be changed or altered.

You can refer the link given below to troubleshoot for the issue.

Brandon, the link discusses failed USB Synchronize and Incremental backups, and the solution is to switch to the copy backup type; but this was a copy backup type.

Hi OriginalGabriel,

I would suggest you to contact WD’s Technical Support about this.

I have this same problem.

Me too. Usually it fails, and if it doesn’t fail, the My Cloud Mirror (2. Gen.) hangs on Sync or on Copy after some time. The device is still pingable, but no file access, no web-UI-timeout and SSH-timeout.
What I tried:

Media indexing is off
stop indexing of photos mentioned in other threads
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Firmware is the most recent, I even made a (system only) reset of the device. Any more advice? There are plenty of reports about these issues and it is impossible that these problems are still not solved after so many years.

I face the same problem with my My Cloud Mirror Gen 2. Every time when I plug the external drive (with some data inside already/ blank drive has no problem) into it to backup the data, the unit crashes and does not respond at all - even with the rest button. Hope anyone has a solution to fix this issue?

We used to get this error repeatedly also. Now the first time we get it, I rename the previous backup and recreate my incremental or full backup (whichever failed) and it’s good again for another 3 or 4 months. For a while, it would be pretty regularly, but after the last update, it happens infrequently now :slight_smile:

I am having a similar problem trying to back up my newly acquired and fully updated EX4100. I keep getting “Backup failed. Please check your system settings” but cannot found any system setting that I can check to resolve this problem. Can anyone help?

WD offers me a replacement of the device, but I fear that this will not solve the problem which seems to be not a singular issue.

Did anyone have success with replacing the device? Did the USB backup issues go away?

Same here. Sometimes a job will succesfully run, usually they dont… I really want a USB back up!
Has anybody come across a fix for this feature?

I’ve been experiencing this same issue lately, and have seen it for years on multiple MyCloud products. The system does not seem to be well designed to support USB backups. It always makes the OS crawl to a near halt with an unresponsive dashboard, eventually the backups begin to fail. The only solution I’ve found is to shut down the NAS, unplug the USB drive, start the NAS again, and then reattempt the backup. Usually words,

Still the same problem. I had it on My Cloud Mirror and I have just upgraded to My Cloud EX2 Ultra and exactly the same is happening. It seems to me that unspecified interruptions from continued use of the pc will stop the backup. Furthermore, apart from the blinking neon on the front of the backup hard drive, there does not appear to be any indication on the pc that the backup is still running - that assurance at least, as with anything else being copied, would provide some confidence that things are working rather than simply having to wait for the ‘backup failed’ message.

Same here. MyCloud fails to back up on the USB drive all the time. Some folders backup but not others. I can synchronize already existing backups but not create new ones. Also, some failed backups created folders that can’t be erased. All very user friendly!!