My Cloud Mirror to USB Back up keeps failing

I have just purchased a WD Passport Ultra 2tb USB drive for the sole purpose of making a Back Up of my Data Folder (Photo/Videos/Documents etc), but every time I try, using the WDCloud Dashboard, I get back up Failed.
I am on the latest firmware for the My Cloud Mirror (2.11.142) and the USB drive is formatted in NTFS.
I don’t know what I am doing wrong. Is anyone else having issues with USB Back Up’s
Thanks
Mick

Hi there,

Try to restart the drive to see if you get the same issue when you try to do the backup to the USB.

Hi ArMark.
Thanks for the reply. I re-started the drive, but it still failed,when I tried to back up the Data_Folder.

Just a quick update, I have managed to get it to back up some folders, I have had to create separate back up jobs per folder i.e.
Photos_Folder
Music_Folder
Documents_Folder
etc…
This seems to work without failing, apart from one folder which is my Clipart folder.
It Fails every time I run the backup, I have tried deleting the job, and recreating it, but it still fails.
Regards
Mick