Backup Problems

Has anyone else had problems with the backup software? I have an external drive attached to my NAS it consistently fails to backup. I have tried to limit the folders and volume of each backup, created new ones, and reformatted the disk. Still, it continues to say backup failure.

If you have any ideas or suggestions to resolve this issue, I would be grateful.

Thank you.

What specific “NAS” name and model? What firmware is the unit running? What is the specific error message that is being generated indicating the backup failed? What “backup software” are you using? The backup app within the NAS (if so what it’s name) or software on the computer? Have you tried a different external drive as a troubleshooting test?

I am using WD MyCloud EX2 Ultra.
Firmware: 5.22.113
WD USB Backups App

I have tested the external and it is operating normally.

Have you tried a different external hard drive?
What brand/model is the problematic USB external drive?
What is the specific error message generated by the WD USB Backup App?
Is the USB drive formatted for a My Cloud supported external USB hard format (for example: NTFS)?

Hi Bennor,

Thanks. I have not tried a different external hard drive because this one used to work and now I get the message “Backup failed. Please check your system settings” which doesn’t make a lot of sense. The USB external drive is a Seagate external harddrivie. As for the formatting, as I said, it used to work so I am confident that the formatting is correct.

Check to see if the external drive is full or that it has enough space to hold the entire backup of the My Cloud unit (or what ever is being backed up). And as a troubleshooting step, use another external hard drive as a backup target. The following WD Knowledge Base Article may have some suggestions (if you haven’t seen it already):

My Cloud: USB Copy, Synchronize and Incremental Backup Failure

There are a few similar past discussions, if you haven’t seen them already, that may have further ideas or suggestions.

My Backup app started to fail recently as well. The issue was that the the app itself creates folders and subfolders but with root as user/group and different read-write permissions than if you create those folders.

What fixed it for me was to SSH into MyCloud and chown and chmod the folder and subfolder created by the app.

chown john:share BackupFolder
chmod +rw BackupFolder

Replace ‘john’ with your user name. Also replace ‘share’ with another group if you use one.

After that the app can proceed with the backup.

Hi JohnRey,

Thanks for your ideas and thoughts. I am not sure how to proceed with your fix. Although I see myself as techie, I guess I am not so techie to enter into the back end solutions.

You would use SSH to issue the commands.

My Cloud: Access Using SSH (Secure Shell)