MyPassport Wireless Pro All LEDs flashing


#1

Hello,

I have a My Passport Wireless Pro, and it’s having some serious issues, I think. Sometimes, when I turn it on (it worked fine for about 6 months, although I did have the issue every now and then) it goes through the boot sequence and then flashes all LEDs rapidly. I have done a reset of the drive by holding the power and battery/SD import button until it restarted, and it seemed to erase itself (the WiFi LED was on, and the HDD LED was flashing). After, it booted up fine. I performed a firmware update by downloading the file to my computer and after restarting, it flashed all LEDs again. Could this be a hardware issue now? I’m sure it isn’t meant to behave like this, right? I don’t use any of the streaming applications, so I don’t think it’s indexing or scanning. Also, sometimes when I boot the drive, it makes this terrible high pitched grinding noise. This makes me wonder if it’s a problem with the disk itself.


#2

Here is what I would do:

  1. Run scandisk and make sure your drive’s file system is healthy. You can also see if this tool helps - https://support.wdc.com/knowledgebase/answer.aspx?ID=940&s=
  2. If you can connect the drive to a computer, duplicate a copy of your data to another drive so you have a backup.
  3. Reset the drive to see if you can bring it back
  4. If #1 shows file system issue, try to use NTFS or HFS as your file system instead of exFAT.
    *The grinding high pitch noise sounds strange. Contact WD support if you need further assistance
    https://support.wdc.com/contact_phone.aspx?h=4

#3

This just started happening on my drive. I’ve only had it for a couple of days.
WD Support, what does this mean when all lights are flashing blue??? !!!

Yet another disappointment with this device.


#4

I gave this advice to another the other day