MyCloudEX2Ultra - Network Disconnect Issue


#1

Device: My Cloud EX2 Ultra 4 TB - Firmware 2.31.149 (Updated Sunday, December 09, 2018)

Network Setup:

  • Static IP address assigned
  • Connected to Switch
  • UPnP

Usage: Save and share Word, Excel, PPT documents for home business network. Usage is very low to what it can handle.

Access: I have mapped the ip address and connect to it accordingly.

Every day I have to power cycle the My Cloud EX2 device to have it recognized on the network. I have several devices on the same switch including network printer (with built in storage to save scanned documents), time clock, and other computers that don’t face this issue. All computers on the network have same issue that it cannot connect to the My Cloud NAS device.

WD My Cloud EX2 Settings

  • Cloud Access turned off. I don’t want access outside network.
  • Energy Saver : Drive sleep off, LED on, Power Schedule Off
  • Network Setting: Static ip address, IPV6 off, Link Speed: Auto, Jumbo Frame Rate - Off, (All off: FTP, AFP, NFS, WebDev, SNMP, SSH, and Dynamic DNS), Network UPS off, Windows Services OFF, Remote Server OFF, Port Forwarding OFF
  • Media - All off
  • System Diagnostics - All working fine

Tried Network Solutions that did NOT resolve my issue:

  • Ensured UpnP is enable on network.
  • Power cycled all computers.
  • Tried to update to new firmware 2.12.127 manually but received error “Upload firmware failed. Try again.”
  • My Cloud interface does not recognize any new firmware release.

Solutions that worked:

  • Power cycled network switch and router. This means I have to take everything off line and other network users have to wait for network to restart. This is not an option for a problem that occurs daily.
  • Power cycled My Cloud device. Works temporary then the next morning same issue.

If all my other networked device (on the same switch and network) always stay on and have no issues then its telling me that its the My Cloud device.

I am very frustrated with this device and do now know how to resolve it. When it works its great.

What settings or changes do you suggest? Please advise.


#2

Hi sa_sa,

We have sent you a message. Please check your Community Message Inbox.


#3

03/14/2018 Update

Tech Support reached out to me and asked me to do the following:

  1. Update firmware manually.
    https://support.wdc.com/knowledgebase/answer.aspx?ID=26961&lang=en

  2. Perform a reset.
    https://support.wdc.com/knowledgebase/answer.aspx?ID=13980
    Option A: 4 Second Reset (Reset with Power On)

  3. Perform a 40 second reset.

    Option B: 40 Second Reset (Reset with Power Off)

I performed the above several days apart to, see if any worked, but it has not helped yet. I am waiting for WD for next steps.