MyCloud, Where have all my files gone?

Hi Everyone,

Up until yesterday my MyCloud had been working fine,… I.E. I hadn’t copied anything to it for a few weeks.
But over the last couple of days I have been slowly moving my video files over to it.

Everything seemed to be going fine,… I use the MyCloud through a firetv running kodi, and the last program I watched was an episode of the knick.

So I turned on my laptop today only to see that my 3tb MyCloud is now only a 90gb MyCloud,… and the only folder visible is under Public/Shared Videos/TV/The Knick/Season 01

Everything else has gone.

Also “Media Serving is turned off”

But if I open open the dashboard on my win7 laptop it shows that I have 2.1TB Free, Diagnosis is ok.
I ran a short diagnosis and that came back as okay,… I rebooted the unit,… but still the same,…
Then a call to WD who told me to try Settings/Utilities/System Factory Restore/System Only/
This did nothing to help.
If I go to The Dashboard and click on to “Capacity” it shows a pie chart of everything that is on the HD, except I can no longer access it, apart from the one folder.
I was then told by WD that the only thing I could do was return the unit for a replacement HD and that they knew of a company that could recover the information… (I don’t think my pockets are going to stretch that far).

It does seem very strange that the very last item I watched is the only one still visible to my laptop.
I was told that the rest of the HD had become corrupted, and there was little I could do about it.
I have intentionally not updated the firmware as I was told that it would make a bad nas even worse.
Also WD said that a fw update would not make any difference any way.

Does any one have any advice for me please…
This has only occurred over night, and no one else has touched anything on my network.
p.s.
everything is hardwired except for my laptop.

Thanks chaps for any advice or help…

I would SSH into the MY Cloud and run a few commands. The following commands will let you know if your video files are gone.
cd /
df -h
cd /nfs/Public
ls
cd *Videos
ls

RAC

I use the MyCloud through a firetv running kodi, and the last program I watched was an episode of the knick.

How are you accessing the MyCloud from the FireTV/Kodi?

Using DLNA? Or using SMB?

So I turned on my laptop today only to see that my 3tb MyCloud is now only a 90gb MyCloud,… and the only folder visible is under Public/Shared Videos/TV/The Knick/Season 01

How are you viewing the contents of the MyCloud folders from the laptop?

Using DLNA/a media player? Or using File Explorer

If you’re using DLNA, it’s possible that Twonky has forgotten where it should be looking.

I’d also suggest using SSH and having a proper look around using the Linux OS that powers the MyCloud.

It’s also a reminder that any hard drive can fail, at any time, and that a backup routine is essential.

Thanks for replying chaps…

Forget about twonky, I don’t user it for anything.

Firetv accesses MyCloud through SMB.


I decided to try something, before unplugging the unit… I turned on my old XP tower, which is hard wired to my router,…
As usual any network drives always show up as “Disconnected” but I’m used to that now.
I just double click the drive I want to view and give it a few seconds and up it pops.
So I tried the “MyCloud” on my xp machine,… and guess what,… everything was there.

Back on laptop, only showing as 90GB still.

Ages ago I created another user profile with admin privileges in case of problems,… (it’s only a small 256 gb ssd, so it’s not used for anything).
I logged into that user profile and lo and behold I would have been able to create a new public folder share if I wanted to.

So now I’m left with the problem being with my win 7 user profile.

I went back to WD,… (not the best experience in the world)… and I was told to “right click” and disconnect the share… I did this and a large red X over the shared folder box with a word that said something about sync (x-sync) or something like that.
The WD rep said that was normal for when one disconnects a shared folder.
A reboot of the laptop and I was able to re-create the shared folder at full size.

This is the weirdest thing I have seen happen,… and I’m at a loss as to the reason why the laptop only showed the last viewed/watched folder on the firetv.

I wouldn’t mind but the laptop wasn’t even turned on.

Theres only three things of importance that I did yesterday, …
1 A full anti rirus scan using kaspersky.
2 A full scan using malewarebytes

and 3… Somehow I accidentally turned on Microsoft sync centre,… when I right clicked on a file (meaning to read it, but my finger slipped and the next thing i knew sync centre was running.
I tried to turn off sync centre with Ctl Alt Del and task manager, but it was not listed, so I ended up going into “services” and finding Sync centre and changing it to manual instead of automatic.

whether this had anything to do with what happened today I really do not know.

the only other thing the wd chap told me to do was to go to “my computer” network/ and double click “WD My Cloud” I did this and for some unknown reason my laptop wanted to access microsoft updates for a driver,… after about 10 minutes or so I received a failure message that no driver was available.

the main thing is that it all seems to be back to normal, although i’m now hesitant in using kodi on my firetv.

The only time I’ve had problems before was with my router attached usb hdd, during a power cut i would end up with corrupted data.
Once I changed it to a hdd that powered down its been fine.

To be honest I don’t know if my problem is resolved as I’m not to sure how the problem occurred. but fingers crossed its okay now.
p.s.
my unit must be quite old because I looked on the WD page to create a safepoint http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10428 and soon realized that my unit is running OS1.
I was thing of getting a 3tb HD and attaching to the rear of “my cloud” and backing up what is on there. although I’m not to sure as to how long it would take to backup 780GB of video data.

I’m glad your a re backup. The transfer of data would be faster. If you did it from the My Cloud device. Otherwise it has to be copied from the My Cloud to your PC and back.

RAC

Hi rac8006,

So are you saying that if I wanted to create a “safepoint” with a connected 3TB external hard drive to the back of the nas it will do this as a backup…

nas > pc > nas>external HD ??

I think the only advantage of using SafePoint to a USB HDD connected to the MyCloud is to allow the MyCloud to perform the backup automatically.

In my experience, the USB interface on the MyCloud is utterly dog slow, and it’s far quicker for me to stick the USB HDD onto my PC, and backup from MyCloud, through the PC to the USB HDD. I don’t think it should come as too much of a surprise that WD themselves suggest this connection setup when transferring large amounts of data from a USB HDD to the MyCloud.

Then there are the many problems reported with actually accessing a USB HDD connected to the MyCloud.

And, given the number of problems people seem to have with SafePoint, I think I’ll stick to a backup utility dedicated to the job; a backup utility that is unreliable is probably worse than useless.

Time to back up 780GB of data from a MyCloud will depend on your local network speed. For a gigabit ethernet, users generally report about 50MB/s, which would take about 4.5 hours. But that should be a one-off job, and a decent backup utility will thereafter only need to copy changes.

Thanks cpt_paranoia…

No problem with the gigabit ethernet… 4 to 6 hours, … that sounds okay,

I’ve just re-read your details and I think I understand what you mean now… External 3tb hd attached to hard wired tower or laptop via lan,… just a pity I don’t have any usb3 ports. I think it would have made a lot of difference in speed.

I’m also thinking about building my own nas with an old tower with two hdds the same size in raid.
I’ve had a look at FreeNAS and Amahi,… just a pity that one can’t build it smaller.
I suppose that’s where pre-built units have got one by the short and curlies.
I was thinking about getting a ‎Synology DiskStation,… but there seems to be just as many people moaning about these as there are seagate of wd units.

I do find it strange that wd recognize that there are so many problems with there units.
But over the phone they disregard any mention of problems including any information one tells them from there own forums.
It’s almost like there forums don’t exist.

Given that WD Support don’t venture into these parts, I’m not surprised…

This is becoming a right royal pain in the backside… It’s happened again,… win7 laptop can only see the very last folder that was played through kodi,… how the hell can this happen.

It just doesn’t make sense,… the laptop wasn’t even switched on.

Just had a quick look at the firetv,… and guess what,… that has no problem seeing my media.
As a quick test, just to make sure, I tried an episode of “walking dead”, played straight away.

The downside to this is that I cannot copy anything to the mycloud…

windows 7 still says 22gb free of 90gb… what the hell.
Totally no point in contacting WD,… there robots don’t seem to have any decent answers.
Has any one here got a clue as to what might be happening.

Because right now, it seems I’ve got to disconnect, reboot, and remap everyday to keep this thing working… It has to be something on this win7 laptop that’s causing this to happen.
any ideas please chaps…

When you say last folder. How are you looking at it? Windows Explorer? Verify that the laptop
has file sharing enabled. Does the My Cloud show up in windows explorer network folder? Can you SSH from the laptop? Need to gather data before you reset every thing.

RAC

Yes mate, Windows Explorer,… The very last folder that was used on the fire tv is the only one being seen by windows explorer.

example:
Computer >Public(\WDMyCloud) (Y:) > Shared Videos > TV > The Knick > Season 01

Everything for Season one is in there, srt files, .nfo and .tbn files.

but nothing can be seen other than just that folder.

File sharing is enabled because I can easily see everything that is on my router attached hdd, I can copy from and to it. and edit files if needed.

I went through the process of opening “my Computer” and right clicking the mycloud and selecting disconnect.
Doing a reboot, and then using the WD Quick View icon on the task bar to Map the “Shared Video” folder again.

Once again everything is back to normal until I run the firetv and watch something. I;m wondering if the mycloud is somehow locking on to the last viewed/watched folder and then only presenting that folder when the laptop is booted.

(But that’s impossible because my knackered old xp machine can still see everything.)

p.s. WD already had me do a reset and that cured nothing.


update:

I have purposely stayed away from the folder “the knick” I’ve watched a few different films, and tv shows,…
and lo and behold… this morning I turn on the laptop and the only folder view-able again is “the knick”.

with 22gb free of 90gb. How the hell does this thing even come up with these numbers.


1 day later.
Streamed from an ipad 2 last night… didn’t look at “the knick”. But streaming was fine.

I’ve tried asking over at kodi forums to see if any one there may have some ideas as to why this thing does this.
Today turn on the laptop,… yep there it is,… 21.8gb available from 90gb.
and only one folder viewable,… exactly the same as before… “The Knick” “season 1” folder.


Another quick update… But I’m hoping this may be what is causing the problem,… but I’m only guessing…
If I go to windows explorer,… I can see all my drives available, but under “network Location” If I just high light the “My CLoud” at the bottom of windows explorer it states what the file system is,… and it says CSC-CACHE.
Does any one know what this is,… and could this be the cause of my problems. (but as I said, I’m only guessing now).

I’ve just realized that the size of the MyCloud is exactly the same size of my C: drive… How the hell did this happen??