Mycloud not visible on network

The only thing I see missing in your list is, reboot the router. Try that and see if it shows under Network.

If that does not work, try this.

Hi Cat0w,
Thanks for your reply.

I rebooted the router, no luck.

When I go to add a device as per the second suggestion, the MyCloud is already listed (but still not showing on the network). When I click on WDMycloud Properties and go to the hardware tab\properties, I am not able to update the driver’s (it says no drivers to be installed for the device). If I click on the UPnP tab, it has a hyperlink to a webpage (which part of it is IP address) - when I click on it takes me to a page called “Twonky” - which came about around the same time I started having issues.

Do you have any other suggestions I could try?

Have you tried mapping the shares as network drives?

Since you can get to the Dashboard and the Twonky UI, you obviously have no network connectivity issues with the MyCloud.

when you say ‘restarted’, what do you mean? Power cycle? 4-second reset? 40-second, power-up reset?

A power cycle doesn’t change much on the system; a reset is required to fix most weird operation.

Hi cpt_paranoia,
The tablet has been shut down/restarted many times since this issue. It was also an issue on a previous Win10 Surface pro 4, so I don’t think it is the device.

I have unplugged the power to the MyCloud a couple of times and to restart it. I have not done anything more than that - concerned about data loss.

I have unplugged the power to the router and restarted it.

What is the best/safest option next for the MyCloud?


Hi cpt_paranoia,
I did the 4 second reset on the MyCloud, and restarted my tablet, however that has not fixed it.
Will the 40 second reset delete any data? Is that the next thing to try?


An update to what I have tried:

  • another port on the router
  • a new network cable between the router and MyCloud
  • connecting the MyCloud to the network port on my tablet dock (now the MyCloud is back on the router)
  • turning all firewall/security off
  • manually mapping the drive

I can still only get to the device settings, twonky, and cloud access any data (loging into

I still can’t access the data via explorer.

I too am having the same problems but I can’t even log in to my dashboard as I get an error saying “this site can’t be reached” and I have tried on a number of browsers.

I was able to see the NAS on my network a few days ago but it has gone despite the restarts etc, nothing else has changed for me so I don’t know why all of a sudden it’s disappeared from my Windows 10 laptop.

Hi BJWest - I feel your pain… I have spent days trying different approaches. Was working fine, with remote access, now nothing - only access the web.

I don’t expect my advice is worth much, but have you tried to access it after turning off all of your firewall/security?

Hi Geoff, yes I have tried the firewall/security methods, I have even tried everything from this microsoft support page

This is so frustrating, I am starting to think the issue is with the NAS device and not a windows issue.

1 Like

Have you read this thread:

I finally have had some success by doing a 4 second reset on the NAS!

I had the same problem and it was driving me batty. The 4 second reset on the My Cloud worked. Thanks @BJWest @geoff5

1 Like

Just putting in my two cents as i have been searching far and wide for a solution to this, and nothing on the forums has worked as of yet.

My particular problem, and excuse my naivety in computer terms… I needed to make sure the WORKGROUP name matched the WORKGROUP that the rest of the office and devices were on. As soon as I did this, the mycloud showed up in network menu and I could browse the files through explorer.

This is a well-known issue with Windows 10. 75% of the time the following will fix it:

Go to Windows features and turn on all SMB1 options.
Go to Network Adapter settings and make sure NETBios is ON.
Make sure file sharing is set to ON.

25% of the time the Mycloud will remain unavailable to NETWORK or EXPLORER.

Go figure!!!

1 Like

Well I used your recommendations and they mostly worked. I could not get the drive to pop up when I wanted to save a file from a program. So, I decided to go back to the explorer and MAP the drive to a letter. Guess what? It appears as though that process is working even after several reboots. Thanks for the help.

This method worked for me very quick

I’ve found that, even when you can access the NAS over the network, it invariably takes quite some time for Windows 10 to poll the network and have the drive show up in NETWORK or EXPLORER. To get around this, I now use Advanced IP Scanner to access my (several) NAS drives.


I have a strange issue. After following and configuring exactly same settings on my three pc in same lan (same workgroup, enable smb feature, enable netbios over tcp/ip v4, driver update in devmgmt.msc) my wd mycloud ex2 is visible on only one system at a time under Networks while its not visible on other systems. After I shutdown that system where it was showing earlier, my cloud ex2 start to show on another random system but not on another powered up machine. When the shutdown second system it start showing on third system. I rebooted all my systems, my cloud ex2 as well as my router but issue remain the same. Has anyone using multiple system in LAN has seen or faced similar issue. If yes we’re you able to resolve it.

Please note that wd my cloud ex2 is in same workgroup as my three systems.

Kindly advise.

I tried this and it’s still not working. My EX2 is still showing up as a storage device. Is there anything else I can try ?