MyCloud Mirror Gen 2 16TB drive failure?

I’ve had this NAS since October 2016 and it has never given me any grief. I use it mainly as a DNLA media device and it is set to RAID 1.0 configuration. Recently and for no obvious reason, I noticed it was buffering during playback. It would only happen once or twice. A couple of weeks ago I built a new Windows 10 machine and last night I tried to connect it to my NAS. The dashboard was incredibly slow. Meanwhile, I could hear constant disk activity. I just assumed it was having a bit of a hissy fit and rebooted it. Once it rebooted, I did a quick check on it and it reported drive 2 health bad. I am now doing a full system scan to see what’s going on. It reports system health and RAID health as good.

I tried that Digital Lifeguard program but it couldn’t see the NAS at all. I just want to make sure that I have checked everything before stumping up AU $400 for a new 8TB WD Red drive.

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/3534

I replaced this faulty drive with a WD Red 8TB.

Last night the other drive also suffered a Drive S.M.A.R.T. failure, the second drive to fail in less than 12 months.

A call to WD Support revealed that this drive is actually a WD Green drive, not a Red.

I also found that the enclosure was so hot I could only just hold the drive when I removed it to get the serial number. The support person on the other end of the call advised me that this heat could damage the new drive and might have been caused by the remaining green drive.

Can someone please confirm or deny this so that I can decide my next step? If it is an enclosure problem then eventually I will have to replace it, probably with a PR2100.

But if WD won’t come to the party, it will be a Synology.

When I bought this unit, I was definitely under the impression that there were two WD Reds in it. This was clearly not the case and I am now investigating what can be done about it. I don’t know if WD’s RMA applies to Australia.

If not, I will investigate to possibility of opening a case with Consumer Affairs here.

Put a new drive in it and rebuilt. I’ve been running it with the lid open. Temperatures are insane - almost too hot to touch the drives. Range is between 53 and 59 degrees and I’ve no idea what the peak temp was. Now the rebuild is finished I’ve shut the device down to try to protect it. This is four shades of wrong.

Interesting that you find mid 50’s too hot. My MyCloud EX2 has two WD RED 10TB drives in it (5400rpm) and they both run mid 50s. My MyCloud Mirror has two 4 TB WD RED drives (5400rpm) and they, too, run mid 50s (and have been doing so for 5-6 years).