MyCloud keeps disappearing off network

Even though the blue light remains on my MyCloud, it keeps disappearing off my network. I have to unplug and then power it up again for it to reappear, this can be several times a day. I am using it with windows 10.

See my thread from yesterday:

Seems like a factory reset solved the issues for me.

be careful of your terms, a system only restore is the only restore that leave data and shares in place. the quick or full factory restore wipes all data and shares

Yes, a system only restore it is, thanks larryg0
I hope I didn’t make anyone do something stupid with my incorrect terminology…

When you say it disconnects and the blue light stays on what are the rear lights doing? If they are both on and working have you checked your router?


Thanks for the replies. The router is working fine, so far I have changed the mycloud settings to a static ip and also turned sleep mode off. It has remained visible all day, so hopefully that will have solved the issue. I have not reset it yet and will take care not to wipe all the settings and data.

Sleep mode should have nothing to do with the device disappearing from the network.


This is also happening to me… suddendly it seem it hungs and disappear…

Any help?

Same thing here. It keeps dissapearing.
Really annoying!!! Has anyone found a solution for this?

Since turning off sleep mode and changing to a static ip this has solved the problem.

Sleep mode should not effect the connection. My device would only wake up at 3:00am
each day when I didn’t use it. No problem with losing the connection. The static IP
most likely fixed the problem. Another way is to leave the Device on DHCP. Go into the router and reserve an IP address for the Device using the mac address.


Sorry to be dense, but how do you do a system restore?.. and How do you do a factory restore?
So far, I have been 3 days trying to back up 65 GB of data, and I still have 10 GB to go.
I have to just sit here watching paint dry, and kick it back into life every 10 minutes or so.
Not quite what I had in mind when I set it up.

WD Support documents detail how to reset and restore a My Cloud:

I had the same issue. After reading this post, I tried the following one at a time:

  • Power On Reset - drive came back online, but disappeared again.
  • Power Off Reset - drive came back online, but disappeared again.
  • Static IP - no effect. turned DHCP back on.
  • Turn off seep - drive is working now, no longer dropping off the network!

I noticed some posts here indicated that turning off sleep would not fix the issue, so I left it for last. Whether or not it should have fixed the problem is irrelevant to me, as long as it did fix the problem.

Seconding D_L1. Had this issue, found this thread, read all of it, decided to try disabling sleep first - and the problem is fixed.

Stopping the sleep may mask the problem. But it is not the problem. I have three My clouds they all have sleep enabled. They have never disconnected from the network. My setup is all three My clouds have DHCP set. The linksys AC1900 router is setup to give each My Cloud a specific IP address based on its macaddress.

Likewise. Sleep enabled, drive never drops off the network.

I get what you’re saying, @rac8006, I really do. And you’re probably right - sleep probably isn’t the underlying problem. It’s not impossible, but it doesn’t seem probable. The thing is, repeatedly telling people here that this workaround won’t, or shouldn’t, fix the problem is extremely counter-productive given that clearly, it does, in fact, fix the problem for those affected. It may well be an ugly work-around, but until a proper solution that actually works is offered up, it’s what we’ve got. Multiple people in here have tried all the other proposed solutions without success.

To fix the problem requires information. Does the ip address change when it disconnects? Are there any alerts sent to the user when it disconnects? Are there any errors logged when the disconnect occurs? Exactly what devices are connected to the network.
Maybe you could try downloading the wakeonlan program from:

When you run this program it will give you a list of all devices on the network along with there ip addresses. Run it once when the My cloud is connected. Save the output. Then run it again when the disconnect occurs. Compare the results. Did the ip address change? Does another device have the ip address that the Cloud had previously?
Try that an post the results.

In my situation, I’d already assigned a fixed IP to this device, like I do for all non-mobile devices in the office, before I even started to run into the problem. I have a small network, with only 4 computers, one printer, and the MyCloud connected to a single router. At the time, the only mobile device in the office was my own cell phone, which had wifi disabled.

In my particular case, the router is also the modem for our satellite internet service, which is a HT2000W leased from HughesNet.