MyCloud FTP port forward on router ZTE F660

Hi there! I’m in trouble to get remote access to MyCloud using ftp client. First of all, the ftp on my local network works fine. at dashboard I enabled ftp, enabled ftp port forward 21. I have a ZTE F660 router. I was setup the port forward to port 21. tried to access on my mobile using mobile net. "no route to host… "image
mycloud ip: 192.168.1.5
what I did wrong? any suggestion appreciated!

Duffy

Are you using an FTP app on your mobile device? Is your ISP blocking inbound port 21 connections?

The following web page (if you haven’t seen it already) gives general directions for setting up port forwarding on that router.

https://portforward.com/zte/f660/

One can use websites like http://canyouseeme.org/ to check/test for open ports on their broadband connection.

@Bennor yes, just got through that website. I’m using total commander and ftp plug-in on my android. the canyouseeme.org came up with the same error message “no route to host” (actually the site has problem with all the ports, but still have net, and the mail is works fine…so?). is my ISP blocking port 21? have no idea. don’t think so, but how to check?