MyCloud + External drive + Kodi = Share frustration

Hi all

I can’t see folders on external drive on My Cloud, OR on kodi on TV box. Both have worked, but not at the same time…

I’ve got a 3TB My Cloud setup with kodi on an Android TV box. Both plugged directly into my router. That was running fine.

I’ve added in a 10TB WD Elements external drive to the back. At first it wouldn’t mount properly, so I couldn’t see files using my laptop, but surprisingly Kodi saw it just fine and I could setup sources in Kodi without issue.

Following guidance from other threads I changed the name from ‘Elements’ to ‘wdten’ to try to get it to mount. I wasn’t expecting it to work as there were no special characters, but it did the trick and I was then able to map a drive on my laptop and see / edit all the files etc, although rather slowly.

Going back to Kodi to update the paths, I discovered that I could no longer see beyond the root folder of the elements drive.

I try to add a source in kodi > nfs > IP > nfs…

It then shows me four shares - 2 are present and correct in my wd my cloud internal drive.

Then theres Elements (which shouldn’t exist anymore?) and wdten. When I click through each of these, they show no folders, just the parent directory button / dots.

When I add the sources on kodi that’s setup on my laptop, the mapped drive shows up in the root folder, and all works absolutely fine.

So it seems like I can only have one or the other. As the next stage is banging my head on my table, I thought I ask for advice…


Is the Share for the external USB drive configured for Public or Private access through the My Cloud Dashboard > Share page?

Have you tried accessing the My Cloud using SMB rather than NFS?

Also make sure that if you are using the DLNA client within Kodi to access the My Cloud, that you enable Media Serving for the external hard drive Share in the My Cloud Dashboard and that the DLNA media server is enabled on the My Cloud Dashboard > Settings > Media.

Thanks Bennor - all settings correct in the dashboard. I’ve looked at SMB, nothing showing and was confused at how to setup.

However, it seems to have randomly worked, without me knowing what changed. I’d gone through unmounts,various restarts etc, more than once, had the external in my laptop, and tried playing around with sharing within the laptop (even though I didn’t feel like it could help). Nothing seemed to make a difference, was going to try chaning the name back, but it suddenly worked. The old elements share disappeared and the new one showed all folders.

Who knows, but it’s working. I guess moral of the story is this setup can take a lot restarting, all services and drives.

I’m assuming you’re using Kodi v18.8? If so, try turning on UPNP/DNLA in the Setting> Services menu. Then access the drive(s) using UPNP.

If that doesn’t work, set up an SMB link to the drive(s). Similar setup in Kodu to NFS.

I’ve had issues accessing my NAS this week from Kodi. Don’t know what’s going on but it went away all by itself yesterday!