Solution Needed! XBMC, WD My Cloud, & USB Attachment

I am accessing My Cloud through Kodi. It is finally at full capacity so I bought a My Book to attach to the USB port. The issue I have is that the My Book USB expansion is not visible through Kodi. My Cloud recognizes the My Book and it is visible and accessible on my Mac. It is showing up as a Share on the Dashboard and Public is on; it just doesn’t show up in Kodi, any solution???

Can you access it from your computer? Does it appear there as a new share in parallel to the existing one(s)?

In Kodi, have you tried adding a new source and browsing the MyCloud and then down to the MyBook beneath that? Your existing Kodi source is probably another share on the MyCloud, so the MyBook won’t be visible as it’s a different share at the same level as the one you’re using as the source, rather than one within that existing share.

Generally it does work, at least it does for me with a MyCloud Mirror and two Elements drives connected to its USB ports, one of which I use as my Kodi source share via NFS.

I can access it through my computer and add and transfer files to it. It does show as a new share. It reads and writes with no problem.

Thats where it goes South. When I try to add as a new source it’s says it can’t be found or when I browse through nfs it just doesnt show up like the My Cloud does.

I appreciate the response. Thank you

On my MyCloud Mirror I have to enable NFS for each share that I want to be visible and accessible that way (it’s in the properties of the share, if you access it via the dashboard). I would check on yours whether the same is true, and that NFS is turned on for your MyBook share if you’re trying to access it that way.

Are you accessing the MyCloud as a media server (DLNA) or a file server (e.g. SMB)?

If DLNA, have you enabled media sharing on the MyBook share, using the Dashboard?
If file server, have you added the new location as a media source in Kodi?

How is Kodi accessing the My Cloud? Using SMB (Samba) or using DLNA? If using DLNA you have to enable Media Serving through the My Cloud Dashboard on the My Book Share.

I’m accessing My Cloud through file server (NFS) in Kodi. When i browse under nfs it finds My Cloud and all the shares except the USB drive attached even thought the USB drive is showing under my shares on the Dashboard and is set to public. Ive tried to manually add the location but the USB attached drive is still not visible in Kodi. everything works great through the computer and on the Dashboard.

Try using SMB (‘Windows Network’), rather than NFS?

Genius! Wow, I’ll take the dumb dumb award. Thank you

Nothing dumb about expecting things to work via NFS. My suggestion of trying SMB was nothing more than a ‘well, let’s try something else’; no genius, just dumb luck…

It does work by NFS, but you have to turn it on for each share.

Whereas SMB is the default and automatically used for each share.

Hi Darren

Can you give an easy write-up about how to “turn it (NFS) on for each share”? I have 3 I would like to access via NFS from my RaspberryPi. I have tried following several threads here about NFS, but haven’t had luck.

Thanks very much for any info

Sure. This is based on my MyCloud Mirror, but yours should be similar.

  • Log into the dashboard using your admin login
  • Click the shares tab and select the share you want to enable NFS on
  • On the right hand side, you should see the share properties, the middle set being share access.
  • Switch the NFS tab to on.
  • If required, select configure to say which IP addresses can access it, and if it’s read only or read/write.
  • Repeat for each share you want to enable access on.

When you enable NFS you will be shown the mounting point for it - use that in kodi as your source.

1 Like

Looks like there’s no NFS control on gen1/v4 firmware basic MyCloud. No sign of NFS control on Shares tab, or any other settings tabs. Maybe it only appears for USB shares; I don’t have any of those.

Would be odd, as swat said he was accessing his main shares via NFS. But it wouldn’t be the first oddity in these firmwares…

My Mirror is a gen 1 device so thought it might have a chance of being similar. Ah well, worth a try :wink:

I checked the user manuals, too. Mirror is very different for the shares tab; lots more controls.

Could it be another of fox’s WD_crack installs?

Gen1 devices do have NFS, but there’s no control for it. NFS is listed in the appendices as a service provided; that the only reference in the manual.

Fair enough. Looks like SMB is the only way…

Hold your horses.

I’m happy to report that the Gen2 single bay My Cloud DOES have nfs toggles, very similar to what you describe.

I didn’t reply yet, because I wanted to test it in my setup,

Even better :smiley: Let us know how it goes…

The WD product range does have some odd variations in the services and capabilities that they provide, hence why I posted that my experience was on the Mirror rather than the plain drive. And it looks like there’s difference between gen.1 and gen.2 as well, based on what @cpt_paranoia found.

Anyway good luck with it, hope it works!

Yes; just checked the Gen2 manual, and, although the Shares tab doesn’t have as many controls as the Mirror does, there is an NFS switch…