Mycloud Ex4 - Mac network Set up

Hi there,

I’ve just bought this device for my business and so far… not bad. Not great either.

It’s mainly the network performance of it that’s the issue. When you search the device from the Finder, it seems to take an age to find anything.

Prior to the EX4 we used 2 large firewire 800 WD drives in RAID 1 (per device), linked to a Mac Pro Xeon - it worked a charm. Fast locating of files etc but it was the remote setup that we wanted, plus the ability to increase drive space and RAID 5.

To cut a long story… I’ve just done a factory reset on the device to try and speed it up (I was having the 99% cpu spike - seems to have fixed that!) but the searching is still soooo slow. I’ve just used the out of the box settings but put it on a static IP.

Are there some better network settings I should be setting the device to in the dashboard or some drive indexing settings to help speed things up?

Thanks in advance.


Make sure that you are running the latest firmware of the unit and confirm that all the devices on the network are using gigabit connections as this might slow down the response time on the unit.

Link to the latest firmware.

1 Like

Thanks for the reply.

I do have the latest firmware on it but every time I come back in to the office on a morning, I can never connect locally to the EX4.

I have to restart it but it never shuts down and eventually I have to pull the power on it.

Any ideas?

I’ve done some more testing looks as if OSX 10.9 now supports SMB2 ; yet seems to be a bug in it hopefully a patched osx will address this.

Either forcing a SMB2 by using option in EX4 & connecting to server smb://ip or by forcing SMBv1 by using cifs:// results in abysmal speeds 12 ~ 15 MB/s 

Sadly reengaging AFP provides the best speeds for me around 30 MB/s write and 50 MB/s read.

You might take a look at this article for more information

lastly…when I disable AFP completely and force a SMB2 connection to another Mac on the gigabit network my read/write speeds saturate the gigabit link around 105/107 MB/s read write.  Obviously apples has Mac to Mac figured out.  SMB2 is an option on the EX4 and the onus to get that protocol working correctly certainly seems to be on Apple. 

I’ve tried everything, it was too unstable as a platform for my office; drop out, logging on , 500 - service errors I’ve had to get rid and send it back I’m afraid.

I’ve went with a Synology NAS which seems to be very very good. The build quality is no where near as good as the EX4 but the interface and user options and stability are so much better.

Sorry WD - must do better. Shame as on paper it’s a great bit of kit.

I think the Synology was a better bet.

OSX 10.9.2 came out today w/ bug fixes for SMB2.  I enabled SMB2 in the EX4 NAS; disabled AFP in NAS and still can’t connect to NAS w/o using AFPoverIP

Waiting on firmware update from WD…