My Cloud EX4 is super slow

OK, so I was wondering what people are getting in terms of tranfser speeds between the unit and the PC or MAC on 1GB connection.  I can’t seem to go beyond 15megabytes per second.  I average out 11…This is absolutely ridiculous.  Anyone else with the same problem?

Same here, Mac Mini hard wired to AX to EX2. On a good day i get 17 mb/s, but an average of 10 mb/s.

I thought the link on EX4 was supposed to support 1gig… it doesn’t look like it does.  Can someone from WD comment on this?

You are mixing up two different units…gigaBIT per second (Gbps) versus megaBYTE per second (MBps). Bits and bytes are not the same :slight_smile: Besides, 1 Gbps is the rated speed of a network…very rarely does in the real world people get sustained speed of that. More typically it is between 320-480 megabits per second (40-60 MBps) on a wired connection…but YMMV. Having said that, the speed you seem to be getting is much slower than expected. Are you sure you are not using wireless connection, but wired connection? Please turn off the wireless adapter to be sure. Although, I am perplexed because you wouldn’t normally get 11MBps from a wireless connection…it’d be even slower…about 4-6 MBps. But still doesn’t hurt to check that wireless is not being used.

How are you testing on the mac.  I use BlackMagic Design Disk Speed test , free in the Mac App Store.

Im a mac user here to and I have the best luck w/ speed on my ex4 turning off Jumbo Frames in the routers and switches, off on dashboard and unless you’ve changed it… default off on MacOS

I also run lthe latest version of MacOS to try to utilize the Apple’s latest implementation of SMB2 protocol.

I turn off TimeMachine on my EX4 …another drastic option you can take is to disable AFP on the EX4 …which is really… AFPoverTCP just another encapsulation layer.  forcing your Mac to use SMB.   Apple has already started to obsolete AFP.

I get about 30+ MB/s write and about 70MB/s read in raid5 … I agree … the ARM SOC(s) are generally slow dogs.  

In fact the painfully slow natures of this NAS combined w/ what I consider POOR showing of app dev for it an easy target for ridicule and disappointment.  If your within the return period for your EX4 I’d highly urge you to re-consider a Drobo 5N ( esp for a Mac user or the Mac-daddy of the Home NAS Synology.  

I don’t have a Mac.  I was just asking for user’s input.  I was just wondering what the numbers might look like from different OS users.  

This is a wired connection on a CAT5E.  

I know that a gigabit is different than gigabyte.  A gigabit is about 125megabytes per second.  I know it’s in a perfect scenerio, but I’m not getting a half of that… heck I’m not even at 30% of that target.  

In your original post you wrote 1GB…capitalized GB denotes gigabyte…that’s why I had to make sure you understood that.

I understand you are using wired connection, but you did not say whether your wireless adapter in Windows is turned off or not. That is important to verify. Just because you are hard wired in doesn’t mean Windows will use the wired connection, if wireless is also available to the PC.

I don’t have a wireless adapter on my workstation.

I just noticed that if the share is public then the tranfer rate is around 30 megabytes/sec. If it’s not public, then the transfer rate drops down to 10-12 megabytes/sec.

I am experiencing the same thing here…around 10-15MBps.  I am transferring files from my TimeCapsule to the EX4 (move) and it’s so slow :cry:

I have EX4, latest firmware, 4x3GB RED drives, Raid 5.  I am running MAC OS 10.9.4.  and everything is hardwired 1Gbps (wireless turned-off)

I have disabled AFP on the EX4 and forced SMB connection between MAC and EX4.  I am using jumbo frames because I thought that doing large transfer would be better that way.  I cannot change the Time Capsule though which is still connected AFP to the MAC.

I have a strange question though.  Is there anyway to get the two devices to talk to each other or is the MAC always an intermediary in the process ?  Right now it is doing TimeCapsule to Mac and MAC to EX4 if I understand this correctly.  Wouldn’t it be more efficient to do TimeCapsule to EX4 directly but I don’t know how to do that is it’s feasible.

Any help on speeding this up would be appreciated.

Jumbo frames will only work if every device in the network traversal path supports it. You turning on Jumbo Frames doesn’t mean it is being used. Many older routers and even few new ones don’t support it.

Jumbo frames need to be supported by the router, laptop/desktop and the NAS unit.  I tried doing load balanced NIC cards on the EX4, but that didn’t yield too much improvement.  I tried doing file transfers under RAID5 and later under RAID10, surprisingly results were very similar.

Came across this post.

I havent had a chance to test it.