MyCloud and Velop Mesh Routers - My Cloud not showing up under Network

I have a perfectly working MyCloud 2T. Using Windows 10Pro. Using a Linksys WRT320 ACM router, all is fine. I upgraded to a new router - Linksys Velop Mesh MX10 and now the MyCloud does not appear under Network in the Windows navigation pane (left side of the window). SMB is checked and the MyCloud has the latest firmware. All was fine until I upgraded the router. However, I can see MyCloud by running \mycloud-name. Do notice that I won’t see MyCloud unless I do this. Anyone has an idea how I can have the drive reappear under Network? Thanks!

Make sure the My Cloud doesn’t have a static IP address set in the My Cloud Dashboard > Settings > Network. In Network set the IP address option to DHCP.

Also check the Windows 10 Network Profile and ensure it’s set to Private and not Public.

On the router, if your Windows 10 PC is connecting using WiFi, ensure the WiFi setting on the router doesn’t have “client isolation” enabled.

If using any third party security or firewall software, temporarily disable it and see if the issue persists.

Make sure the My Cloud and all other devices are using the same workgroup name (typically: workgroup).

On some Mesh networks its possible devices connected to the nodes (not the main router) will have different IP address ranges than the main router. Check that all devices are using the same IP address subnet range pool.

Make sure to connect the My Cloud direct to the main router and not a Mesh node.

@Bennor Thank you for taking the time to reply. I crossed checked all of the suggestions and still can’t see the WDMyCloud under Network. So you know, I have the PC and WDMyCloud hardwired in the same node and that node is connected directly to the ISP modem. The child modem is standalone at the moment and the IP address is within range. Any other ideas??

Do any other devices (computers, smartTV’s, mobile devices, etc.) on the local network have a problem seeing the My Cloud?

What color is the front LED on the My Cloud? If it isn’t blue then as a troubleshooting step try putting a network switch between the My Cloud and the router.

You may (if you haven’t already) want to check if there is a support forum for Velop routers and inquire there if you haven’t already. Perhaps there is a special setting or configuration option others who use that router line may know about. For what ever reason some NAS devices have issues with mesh networks and it can take some fiddling with the mesh network settings to get things to play nice.

@Bennor I have three other PC’s running Windows 10 Home and they also stopped seeing the MyCloud under Network. I just switched back to the old router (Linksys WRT3200) and I’m able to see the MyCloud under the Network. Very odd.

The LED is blue, I have a static IP address. The only variable here is the router but why??? It’s like the new router has a different language that it doesn’t recognize the WDMyCloud as a networked device. Could it be the the WDMyCloud needs a Firmware update/upgrade? With all of these new Mesh routers, one would think Western Digital is on top of this? Anyway. If you have any other suggestions, please let me know. Thanks again!

That is not odd. That is a very big clue. That means the problem most likely lies with the Velop Mesh router and not the My Cloud.

First general steps, perform a 40 second reset of the My Cloud to reset it back to default.

Next troubleshooting step is to update the Velop router to the latest firmware (if it hasn’t been updated) and perform a reset of the Velop router/mesh devices. At least one person over in the Linksys Community forum (see this link) indicated that fixed their issue of not seeing the NAS when using the Velop router.

If the problem persists, then search through the Linksys Velop Community subforum as there appears to be a fair number of people who are having issues with various NAS devices an the Velop Mesh router system.

https://community.linksys.com/t5/forums/searchpage/tab/message?filter=location&q=NAS&location=forum-board%3AVelop&collapse_discussion=true

Well;

I have this same problem with Asus routers.

Multiple pc’s. I tried every posted fix. Nada. The problem comes and goes.

This is a stated “fix” listed in the new os/5 (which won’t be rolled out to the single bay myclouds); and indeed does seem to work on the one device i have os/5. But don’t feel bad - os/5 has plenty other issues; and I would shudder at how these devices would handle it.

May be specific to certain mesh networks or settings. No problem with a single bay first gen on two Asus AC1900 routers.

If I remember right there were issues with certain other mesh router systems (perhaps from Google and or Netgear Orbi?) in the past.

One thing anyone who is having issues should check beyond ensuring Windows has SMB1.0 enabled is to see if the router has an SMB setting or is somehow blocking SMB broadcasts. Haven’t heard of a router having an SMB setting specific to network clients but you never know. Something on certain routers is blocking proper local network access to the My Cloud. For example someone (in a post from 2018) enquires about Velop blocking SMB broadcasts.

https://community.linksys.com/t5/Velop-Whole-Home-Wi-Fi/Velop-system-block-SMB-broadcast/td-p/1343630

I had the exact same WRT3200ACM router as OP, and also upgraded to the Linksys Velop (not AX) mesh system, and had the same problem. It was a while ago, but if I recall everything worked wonderfully with the 3200, but once I installed the Velop, the MyCloud disappeared from my network. I had to manually navigate to it via ip, and then pin to my Quick Access menu to allow easy access. This was over a year ago, and during that 1+year time, it slowly has come back and is now showing up in my network section. Don’t know what got updated or changed, but it did eventually come back. Just an FYI.

@MaryJaneToker Thank you for your reply. What model router did you get?

I believe I found the fix. We need to disable IPv6. In addition, go the the Velop WiFi settings > Advanced > Turn off all (Airtime Fairness, Node Steering and Client Steering). Do a full router reboot. The WDMyCloud will show up afterward. It appears that there is a glitch with IPv6 and the NAS. The NAS doesn’t support IPv6 so there must be an issue somewhere. I will further test buy leaving IPv6 off and turning the advanced WiFi settings on one at a time and see. However, this is the fix in the meantime. Thanks again @Bennor and @MaryJaneToker for the collaboration. :raised_hands: :raised_hands: