MyCloud not appearing on Network

I set up a new Google wifi Mesh network and reinstalled my working 2Tb MyCloud (model WDBCTXXX). The network is performing but I cant find the MyCloud. I did a Network scan and can not see it or get the ip address. I rebooted the device, connected it directly to the ethernet port on the router, no luck.
On reboot I see the white light and eventually a very dim blue light. Still no joy. Also tried it connected directly to a laptop ethernet port, no luck.
Any suggestions. There are files on it I don’t want to lose.
It is probably 9 years old.
Ethernet port lights are on / flashing, i.e. appear to be working.

If you haven’t done so already, try performing a 4 second reset.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

You are not going to loose your data. The fact that the front LED is blue indicates things are working properly.

Also check the settings of the Google WiFi mesh router. make sure the My Cloud i showing up in the router’s DHCP server reservation list. Also look at other settings like “client isolation” or similar to see if anything is limiting or preventing access between network clients.

I have been able to connect after the reset. Thanks.
Now trying to re-establish the mounted volumes.