MyCloud shows up if directly connected to pc network port but not when connected to router

Ive been trying to get a new mycloud 3tb drive to show up in windows 10. it does appear in the devices and printers menu and its led is blue but accessing the ui fails as well as the setup from wd. however i tried to connect straight to the network port on the pc and all is fine. i can access the dashboard and everything. so its definitely something wrong with the way its setup. id appreciate any help. thanx

Hi there,

Try to check on your routers interface, and check the IP the unit gets from the router an try to access it from the that IP. Hope this helps

There are many complaints of Windows 10 in other threads of Windows 10 not properly seeing the My Cloud. As the prior poster indicated, access the My Cloud by it’s IP address. The problem lies with Windows 10, don’t know if there are any solid fixes that will work for all at this point.

thanx for the suggestions…funny thing is tho that it wont show up in the connected devices on the router…is there any other way to check that ip address?it still shows up in the control panel devices and printers menu but for some reason i cant find it anywhere in the router settings…

Yes, your router or gateway should have an administration page or status page that lists all the devices connected to the router/gateway and those device’s IP addresses.

Make sure that your router does not have [Isolation] set to YES. That will prevent individual clients on your network from communicating with each other.

Also, when you change the hierarchy of devices on the network (from one stub to a different stub; i.e. router vs. switch or router) you should reboot all the routers to allow them to reload their routing tables.

Windows 10 is likely not the culprit but there are times when it seems to be slow in populating the database of devices so …??? I’m still trying to figure that one out.


again thanx for all the suggestions…i was checking the administrator page with all devices connected to the router but the drive is nowhere to be seen…i also could not find the isolation feature anywhere to check if that is the problem…again i tried connecting the drive straight to the ethernet port of my pc and it works fine…its only when i connect it to the router that it disappears…any other suggestions or a step by step guide as to what i should enable to get this to work would be much appreciated…thanx again

one more thing…i tried adding the device manually (using the MAC address) but it still comes on as inactive and its not assigned an ip address…

Did you do a reboot of that router?

BTW, is the Cloud hooked up as DHCP or did you assign a static IP?


i did a reboot several times with no luck and also tried both dhcp and static ip(when i connect it straight to the ethernet port so i can access the ui)