MyCloud access problem - safety question

Hello everyone.

Question 1:

I just installed a new MyCloud NAS in our university laboratory. There are 3 PCs in our lab, all of them (and the NAS) connected to the university network (in ethernet sockets on the wall, not on a router). In order to better explain you the situation, let me name the 3 PCs.

PC1 --> Windows 7 laptop (NAS admin)

PC2 --> Windows XP desktop

PC3 --> Windows 7 desktop

(the IPs are not static)

In the NAS I have created a folder (let’s call it Lab) and all three users have full rights in this folder. All users have a password in order to get access. I want the 3 PCs to have access to the NAS easily, without having to map through wd2go everytime. So I followed the instructions (from the Help section of the Dashboard) and created a shortcut pointing to \MyCloud on the desktop in all three PCs. Everything works just fine with PC1 and PC2. I open the drive via the shortcut, I click the lab folder, I put the username and password and everything goes as it should. However, something’s wrong with PC3. 

After clicking the shortcut and while the window opens, it asks for credentials (it does not display NAS folders before putting username and password - strange thing no 1). After putting the credentials, I can now see the NAS folders. I click the Lab folder and again I am asked for username and password. However, this time access is denied (strange thing no 2) and Windows keep asking me for the credentials again and again. Mapping the drive via wd2go works fine, but it is not an easy thing to do every time. Any idea??

Question 2:

As I described above, I have set passwords for all users. In order to access the Dashboard, you also need a password. Is there anything else I should do in terms of safety (since I don’t want the whole university to have access to our files).

Thank you in advance

Let me give you some more information, after some attempts that I have made. It seems to be some kind of conflict between windows & and XP. I deleted all folders and created a new one. I restarted all 3 PCs. If I access the folder through the XP machine first, then it appears to be a problem for the Windows 7 machines. I am trying to see if a pattern exists but I cannot really find my way.

I know that a static IP would probably be the solution, but it is a little bit of a problem in our network. It seems so easy to have access using \MyCloud… It is a pity it won’t work as it should…

I’ve had a ton of issues of this kind … what helped sometimes was this piece of advice from someone else on the forum:

Don’t access any public shares and THEN try to access a private share, apparently Windows does not allow this, and will ask you for credentials but reject any input.

After lots of effort, I managed to solve the problem, by doing the following… I deleted all folders and then created them again. I tried to connect to the NAS drive first from the two Windows 7 machines and then from the Windows XP machine. Since then everything works fine. To be sure that this was the reason, I tried it again… So the problem seems to be solved when folders (not public ones) are first accessed by Windows 7 machines and then from Windows XP machines (only the first time, after that everything works fine).

Today I added another PC (Windows 7) and I had the same problem again. I guess I have to repeat the same process. However, it is not feasible to delete folder and create them again in order to just add one user, when the drive is used everyday and has a lot of valuable data. 

It would be great to have an answer by a WD technician I guess…

Do you have the same problem when you create a drive mapped to the Lab share?

Go to Control Panel\User Accounts and Family Safety\Credential Manager\Add a Windows Credential. Delete any stored WDCLOUD credential there.

Then, from a command prompt type “net use * /delete”

Make sure there is no backup software, sync software or other that is accessing the WDCLOUD on reboot.

Reboot the computer

Open your network explorer, right click on the LAB share, choose “map network drive”, click on reconnect at logon and enter the credentials

Enter the NAS username for example wdcloud\UserA (this is not a windows username!)

Enter the NAS password.

I did not prefer the solution of creating a mapped drive, because the IP address of the NAS drive in the network is not static (no easy solution since it is not a home network, rather a university network). Everytime the network crashes (this happens every so often) the IP of the drive will change and all mapped drived will have to be re-created. Isn’t that so?

If you use UNC ( \server\share\file_path), Windows should be able to resolve the name to the changing IP address.