Logon failure: unknown username or bad password Win7

#1

Hi. My mycloud always used to work fine with my win 7 pc. I could always access it via explorer with no issues.

I then changed my username in windows. Since then I could only sometimes access mycloud after a restart of pc or sleep, but not after shutdown. I can see the nas in explorer, but it I select it, windows says the username or password is incorrect, even though I did not supply any.

If I then enter a nas username and password, it does not work. Also, windows seems to add the computer name onto the username that I entered. e.g. if I enter john as username, it enters homepc\john .

I just wiped my whole pc and reinstalled win 7. Directly after installation, it worked, but after shutdown it was back to asking for username and password.

Sometimes after lots of logging on and off etc it suddenly works for a while, and then stops again.

Workgroup is set to workgroup on both.

If I go to mycloud.com/setup it says it cant find the device even though the WD mycloud application on pc is connected and working.

Web interface works fine.

I can access nas via phone app with no issues.

How do I get Win explorer to access the nas?
Please help - its driving me nuts!

Thanks,
Philip

#2

You should perform a 4 second on My Cloud and reboot it to initialize with default network configurations. On getting solid blue power status, locally map private shares then map public shares so that you will be able to access My Cloud data from Windows Explorer without any issue.
Sometimes if you map Public Share before Private in Windows OS, protected private shares keep asking for credentials and would be require to use credentials again. So try to map Private Share before Public Share and then check for the issue.

#3

Another 6 months gone past and I still cant access my nas with windows 7. Any new great ideas out there?

done the 4 sec restore
fresh windows install
matched windows username & password to that of nas

image

#4

I note that it is trying to authenticate via a domain controller. (See there where it says “Domain:00A” ?) By default, the SAMBA implementation in the mycloud does not enroll with a DC.

Try clicking the “connect with different credentials” thing, and ensure that you are not trying to authenticate against a DC.

#5

Thanks for the response. If only I new how to loose the DC. ‘00A’ is my pc name that windows requests when you install windows. It automatically uses it as the domain name. On the second try it would write it like this: 00A\username

I have no saved credentials, yet as soon as I click on the nas (left) it says username or password is incorrect. But I never supplied any!!!

#6

this looks like windows 7.

Do you use active directory for anything? Anything at all?

You can change the network configuration to “workgroup” mode if you don’t use active directory. This will stop the default behavior of attempting to authenticate against a domain controller.

First, open the system control panel, and choose advanced system settings.

The “System Properties” window appears.

Next, choose the computer name tab.

Then click on “Change” next to where it mentions workgroups or domains.

A new child window pops up.

If you are currently registering against a domain controller, the first radio button in the child window will be selected and the name of the domain controller will be on the line. You want to be in “Peer to peer” mode, or Workgroup mode.


Further info:

A stock mycloud does not have options to turn on active directory enrollment.

This is why you need to be in workgroup mode unless you absolutely need active directory support.

You will note that my EX2 Ultra DOES support active directory enrollment.

I point this out, because you CAN enable many EX2 features on a gen2 single bay mycloud, but the modification WILL void your warranty.

If you absolutely MUST have active directory enrollment (and yours is a gen2 unit), you will need to install the wdcrack package. See the thread linked below.

The crack works by changing some variables contained in define.js, which enables app support. It will also enable other features, such as active directory enrollment features, with a little fiddling. IT WILL VOID YOUR WARRANTY

Install a version of wdcrack that is appropriate for your firmware level, then reboot the mycloud.

#7

you should also try this, maybe it will help

#8

I had forgotten about it when I posted prior–but you can also map using “net use”.

net use X: //someserver/someshare

It’s a command line driven method, but it ignores your current domain context, and arbitrates against the server you are connecting to. Will ask for user and pass. Then will mount system-wide.

#9

Thanks Wierd_w, but I’m already in workgroup mode:
image

#10

Didn’t have much luck with this. It says my password is incorrect, however the password works for the web interface and phone app.
image

#11

From what I am reading, this is caused by one or more of the following:

  1. you are running a local DNS, and it is interfering with correct name/address resolution. Try the net use syntax with an IP address instead of a machine name, and see if it still fails.

  2. Possibly an issue with the security level policy.

If you try to mount a CIFS share on windows 2008 R2 server, the system still prompt for credentials even if you type them correctly.

Furthermore, if you try using shell command net use , you get the following error:

C:\Users\Admini>NET USE R: \\10.0.0.1\share /user:admin password

System error 86 has occurred.
The specified network password is not correct.

To resolve this issue:

  1. go to start > run
  2. type secpol.msc.
  3. Local Policies -> Security Options
  4. Change the value of “Network Security: LAN Manager authentication level” to: LM and NTLM – use NTLMv2 session security if negotiated
  1. Possible that the system date/time is incorrect

  2. There’s been a reported issue on stack overflow about accounts without passwords set causing this problem. Assigning a password seems to fix it for them. (this is the guest account, so this might be the issue?)

1 Like
#12

Genius!! It worked.
I used the IP address with net use and it worked.
image

After reboot I mapped a drive to a share using the IP address. It again asked for login details. I entered username and password and for the first time almost ever, it accepted it.

I then figured out how to reserve that IP on my router, so hopefully now with my saved credentials I should be ok.
image

It seems my router assigned a new IP after each power failure and this eventually created confusion. (I still cant access by using the NAS name). See, here in wonderful Africa, we have a thing called ‘load shedding’. It happens when politicians buys cars and planes with tax money instead of coal for the power station. Now our power gets turned off for 2 hours a few times a day - not great for electronics.

I dont know who you are Wierd_w, but I’m sincerely grateful for your assistance.
Philip

#13

Any time!

Sounds like there’s a potential industry for short-life building size UPS solutions there then.

Such systems can be ghetto-assembled using charge systems and battery arrays similar to those found in the solar “off-grid” solutions, just tied to mains power, and with a circuit switcher that kicks in when mains goes offline. It’s basically a solar deployment without the panels. If the “Power outages” (ahem) are regular, and predictable in timing and duration, it should be possible to overcome.

Depending on what country you are in, that might or might not be a good lead. “Africa” is a big place and some parts are more… Unpredictable… than others.

I hope your DHCP reservation strategy works to avoid name resolution cockups should the power fail again, but I and others here are pretty much always around to help. We seem to have nothing better to do.