MyCloud Access Issues

I have searched the community and found problems like what I am having, but not exactly. If I missed it, Im sorry!

I am unable to access the dashboard via any browser on two of my PC’s. Both run Windows 10. I can access the dashboard with web browsers on my Android tablets, Android phone and a Windows 7 laptop.

On these two PC’s, I am able to access the FTP shares I have set up, however it looks like it times out when trying to open folders. Anonymous browsing will open some of them. On my Android tablets and phone, I can access it like there is not a problem via FTP software or using the web browser.

I have tried mapping the device in explorer and it seems to work on occasion. It will show an icon, a drive letter and storage but I cant open it. When I try, my PC either goes into an extreme case of ADHD or isnt opening.

Before I jam a broomstick in it and swing it around like a drunken Thor,  anyone got any ideas what could be going on?

Welcome to the Community.

Which firmware revision do you use? have you tried with both the device IP and NetBIOS? Have you tried different browsers or the WD Quckview? If you are still encountering issues after trying, then maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support



Hi, we’ve passed this along to support.

Hi there,

My apologies for any inconvenience caused. Please try running Windows Updates on the Windows 10 computer. When done, the Samba (SMB) protocol will be fully supported. Thank you.

Need Help? Please click below for further assistance or contact us at 1(855) 556-5117

I’m on firmware 2.10.302. I cannot access with ip or netbios. It is only on the Windows 10 PC’s.

It worked before and the transfer speeds were extremely slow the last time it worked. About 300-500kbps on FTP inside my local network.

The WD Viewer software see’s everything in my network but the EX4 (from the Windows 10 PC’s). It sees my router, receiver, other PC’s, etc. I can see it just fine on my Windows 7 laptop and searching for network devices on my Android’s.

Is there an issue with Windows 10?

 > I’m on firmware 2.10.302

I think you may have an EX device; this is the plain vanilla MyCloud forum… Assuming you mean the f/w of your MyCloud device.

I have the My Cloud EX4 Network Storage. The black one with 4 bays.

A mod moved me to this thread.