MyCloud 2T stops working after 30 min

#1

Hello,

I have a strange problem with my WD MyCloud 2T - I have read trough the forum to check any similar issues, but I did not found anything similar. I read tough also this description from the forum: Compilation of Windows 10 Methods, Steps and Solutions but there is nothing else I can improve
The system had worked quite well for about 1.5 years

My NAS WD MyCloud 2T, works only about 30 min after a reboot, after that I cannot access it anymore at all, neither from the PC, or from my Android TV, Android Tablet or Android Mobile Phone…
The LED on the front panel remains BLUE, the LEDs from the backisde (network) are ON and blinking like in normal operation. The device cannot be seen anymore on the network (neither as NAD, Media Center or Storage Device)

After a reboot (unplug) the power supply cable, it comes back again but only for ~30 min.
The MyCould has a static IP defined in the Router (connected to its eMAC), tried also with the DHCP, same issue.
I tried also the 4 sec reset, nothing happens, the 40 sec works but just because of the power reset (the system comes back for ~ 30 min. also if I just reboot it without the 40 sec reset)

The Firmware is 2.30.181
All updates were carried out also on my PC with Windows10
If I make a System Test or Quick Test on the MyCloud device, everything seems to be fine (“Test Passed - Quick disk test completed successfully”

From time to time I get the error from the WD App Manager on the PC saying the there was an error like “power loss detected on Port1”

What could be wrong?
Thank you !
Best regards,
Pavel

#2

When the My Cloud stops working after 30 minutes can you still ping the My Cloud using the My Cloud’s IP address?

Are there any other devices on the local network that have network problems at the same time? Any other network devices that have a static IP address set within the device and not the route?

#3

Yes, I tried the ping-in the device, it works all messages are delivered, no delay no packages lost.
The MyCloud is the only device with Static IP on this network (excepting the router 192.168.1.1)
Until yesterday the My Cloud was on DHCP, with the same problem, today I switch it to a Static IP (connected also to the eMAC of the MyCloud) no change.

I started a Full System Diagnosis (from the Utilities menu) since ~3h, the device is still on and I can access it (I assume the running diagnostic keeps the connection up)

#4

Update: I just got the following error message from the WD App Manager, saying there is an issue with the Drive1
Since this I cannot access anymore the MyCloud, however it is visible on the Network (as a device, media server and as Storage)), but when I try to access the Explorer gets blocked…
Front LED is ON (Blue)

In order to access it, I need to reboot it (cut the power)

SMART Failure

#5

After I reboot it, I got the following error message from the WD App ManagerWD App Manager Notification 2