My Cloud works for a few minutes after reboot but stops after a while

I have a 4TB WD My Cloud that was working perfectly fine for about a year without any issues, however, suddenly it stopped working. On restart, it works for 10-15 minutes and then it becomes inaccessible. It is somehow detected by my router and I can ping it. But the browser cannot connect to the dashboard and neither can windows explorer. It was in a static IP configuration. Please help

What color is the front LED when the My Cloud becomes inaccessible?

As a troubleshooting step have you tried a 40 second reset?

Oh yeah I forgot… I did try both the 4 and 40 second reboots but to no avail. Also for some reason the blue LED stopped working a long time ago. The drive worked fine though. Now it shows white while it boots up and then doesn’t show anything. Just like before.

One question would be is the led turned on in the dashboard? Can you SSH into the device? If you
can you should do a ps -eaf to get a listing of what is currently running. You could then check the logs for any errors.

What’s an SSH? BTW the blue LED does not work for some unrelated reason (this is because the drive worked fine without the blue LED). Also the dashboard does say that the device is initializing when the LED is white

https://www.google.co.uk/search?q=ssh

From what I understand SSH needs to be enabled in the dashboard. But I can’t access the dashboard for more than 10-15 minutes. Should I still try that?

Yes. sshd uses very little memory, and will likely still respond even if the httpd crashes, or the system starts thrashing swap very heavily.

It is useful for seeing what the MyCloud is Actually doing when it goes MIA like that.

I’m sorry I don’t exactly know what the steps are. Can someone please walk me through the steps involved? Also it doesn’t void my warranty does it?

That latter question is tricky…

WD is of the opinion that if you mess with settings over ssh, you have nuked the warranty. Simply enabling SSH, and using it to get diagnostic information (dmesg, top, ps -A and pals) not so much.

Okay. I guess I can take the risk. Can someone walk me through what I’d have to do?

Follow the handy guide…

When you have it enabled, you will need something like putty to log into the mycloud.
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html

Once you get it working, wait for symptoms to manifest, then log in over ssh with putty (or whatever ssh client you choose to use), then run these commands, collect the output, and present it here.

dmesg

ps -A

free

(collect screen grab, since this runs and keeps updating)

top

We should be able to determine what process is misbehaving from that.

Do you have remote access enabled?
Are you serving media (Twonkey).

I had an issue with Apache crashing, which prevented access to the dashboard. I think it was related to either remote access or media server. I think it was just a case of apache having performance issues and either being really slow or crashing.

I disabled remote access and media server and apache didn’t crash after that. Never did figure out how to fix things.

I was always able to ssh into my mycloud and see that apache wasn’t running. After starting apache (/etc/init.d/apache2 start) I could access the dashboard until it crashed again.

I think the 15 minute thing is because there is about that much delay after startup before the MyCloud starts scanning for media files to make thumbnails. That was my experience. There are some real experts on this forum that know much more than I.