MyBook Live 3TB extremely slow after power loss

After unexpectedly loosing power my MyBook Live became extremely slow. It literally takes hours after powering it on before it becomes pingable. UI is very slow as well. Yesterday I tried to do Factory Reset and since then UI is stuck showing the message Initializing device. Please wait. Reloading the page does not help. The message comes back. Front LED is permanently on and has yellow color. LEDs next to Ethernet port are looking normal - upper is flashing, lower is constantly on.

Has anyone experienced such behavior? Is there a way to recover the device?

Thanks

Update: The message went away and popup shows that restore completed successfully, but the unit is still so slow that I cannot do anything. UI times out. Cannot enable SSH because of this. Hard drive plugged via USB to SATA adapter shows all correct partitions. Any suggestions?

Hi @lmcbmai ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask