sorry, new to this hence the reason for a second question is as many minutes.

The Web UI is incredibly slow, to the point that each save or switching to anohter menu option takes between 2-5 minutes, any ideas what would cause this, nothing else on the network is slow.

and yes, I have set it to a static network address



Well mate… I’ll recommend you to reset the unit and if that does not solve the issue you will need to do full factory restore, keep in mind doing a backup  before the restore…

Did doing a factory reset resolve the problem. I cant believe WD hasn’t sent out a fix for this. 

I’ve tried the following posting but that did not work for me. 


this is just painful.

I’ve seen some reports about slow UI on these WD World Books and similar WD drives. 

I’ve tried the SSH trick to edit the hosts file, but mine already has the correct host listed in the host file. 

I’ve tried a power cycle, and that doesn’t work. 

I can’t even upgrade to the lastest firmware because when I do it manually, I end up waiting a long time, and getting a blank screen, with the admin page sitting at a URL that looks like: http://xxx.xx.xx.xx/admin/system_firmware_manual.php?len=en

Is there a way to upgrade to the latest firmware as root, as long as I have the firmware image file available? 

I assume I’m screwed, and that I need a better company to sell me a good backup drive. 

I can’t do a factory reset because I don’t have a drive large enough to hold this drive, which is functioning as my backup drive. 


Recently I did a “top” command from the console and noticed that crappy Twonky was using 90+% of the CPU, I suspect that could be the problem. If I don’t use wonky Twonky, can I disable it?

I’ve found that if I kill the process that is running the TwonkyServer, UI response is greatly improved. 

After killing the TwonkyServer process, you can disable it from starting up again by issuing this command, it basically removes the ability of the startup script to execute.

chmod -x /etc/init.d/S97twonkyserver

To re-enable TwonkyServer, issue this command, and recycle your WDMB:

chmod 755 /etc/init.d/S97twonkyserver