My MBL UI settings is acting up about every hour....VERY FRUSTRATING!

I posted on here a while back about not being able to access my settings feature on the MBL.  I received a good solution (it worked very well), but my goodness, should I have to do it every hour or so?  Talk about a NON-PRODUCTIVE glitch.  This has become very frustrating to me and would like to know if there has been a better solution that someone else has come up with.

Previous disscussion of this original problem of mine can be found here :

The exact same thing is happening now except that it keeps occuring about every hour (give or take a few mins).  I’ve even went as far as backing up what I wanted to keep, and then issuing the command to scrap everything and go back to factory to see if that would help…and of course it didn’t. Has anybody else found a better solution?  My God, I’m just about ready to throw this thing out the fricking window and give up on WD products completely.  No one should have to go through this TIME WASTING **bleep** all the live long day.  Thank you for your time.

Hi DirtyDawg, please check your private messages. 

Yes, thank you.  I’ve checked and responded. Thanks again.

Did the PM contain the solution to your problem?

Unfortunately no.  But I’m supposed to be contacted (probably after the weekend) at home by techs to help me possibly figure out the problem.  Thanks for asking.  Sorry if you were looking for a fix, I haven’t received one yet.  When I get one though, I will definately tell the community.

Well it’s been approximately two weeks since receiving my replacement drive and it seems like the problem is no more.  So I guess, for the moment anyway, the problem I was having is solved. Of course when I first received it, I IMMEDIATELY put my backed up software onto it and until I had downloaded the most updated firmware, the replacement drive was acting up just like the original one did.  This leads me to believe that it had something to do with the firmware (not sure if the firmware version on the original one is the same one I had to d/l for the replacement drive).  Thanks very much for the assistance from WD as well as the forum here on this subject.