MyBook attached to MyCloud


#1

I am trying to attach a 4T MyBook to a 3T MyCloud, but it doesn’t seem to register. I got this when I tried
Event title:Unable to create share

Event description:A share could not be created on a USB device (vendor: Western Digital, model: My Book 25EE, serial number: 574343374B37565539384A37, file system: ntfs, label: My Book, share name: My_Book).

Severity:warning

Event code:1122


#2

Make sure to format the MyBook in a My Cloud supported USB drive format.

It also helps to make sure there is only one single partition on the USB hard drive. Sometimes the My Cloud can get confused when attempting to mount a USB hard drive with multiple partitions.


#3

Error log excerpt suggests it is NTFS, which is supported. However, the above error could occur if the drive has the “dirty bit” set.

Linux will not mount a “dirty” file system as read-write, and that includes the 3rd party Paragon NTFS driver that is baked into the Mycloud series. It will mount it read only instead, which will cause creation of shares and files on the device to fail.

Suggestion: Eject the drive from the mycloud dashboard, hook it to a windows PC and run chkdsk on it-- THEN eject it from the PC, and reattach to the mycloud. See if that fixes the problem.


#4

Reformatting the drive solved the problem. Thanks


#5

I am glad this was resolved for you. I still think a reformat was overkill though.


#6

It was a drive I had used for Lima, so I probably needed the reformat.