MyCloud cannot create share on external USB disk after reformatting

I am stuck with an odd problem - maybe someone on this forum had a similar experience? Any advice is appreciated!

I have two MyClouds (6TB single bay) with external USB disks. Until recently they worked fine, I have media files (music, video etc) stored on the internal and USB disks and share via network, e.g. to my WD TV devices.
Then I wanted to move a MyBook 4TB External Disk from one MyCloud unit to the other, I disconnected it correctly, erased the old data and reformatted it via Win10 PC (NTFS) and WD disk tools, tested it successfully on the PC and reconnected it to the MyCloud. MyCloud recognized the USB disk but generated the following error message:

Event title:Unable to create share
Event description:A share could not be created on a USB device (vendor: Western Digital, model: My Book 1230, serial number: 574343344530333438353136, file system: ntfs, label: MyBook4TB, share name: MyBook4TB).
Event code:1122
Firmware version: 04.05.00-320

I reformatted the disk again, tried both NTFS quick format and detailed formatting via disk management, it worked fine on the PC and passed all WD Tools checks, but MyCloud still shows the same error.

I exchanged emails, sent screen shots and logs and had a remote session with a WD support tech - without success. First, the support person claimed “MyCloud is not designed to use a USB disk for data storage extension or sharing”, I had to point out that this has worked fine until then, and I had to read from the WD manual, which is contradicting the support statement I got.
WD support wanted more time to review the logs. A few days later they sent an email saying that after the latest firmware update, the WD MyBook 4TB disk is no longer compatible with the MyCloud firmware and cannot be used anymore for shares, only manual data backup on the disk is possible now.

I find that hard to believe. For one, shares on the disk worked ok after the last firmware update, the problem occurred only after my reformatting. Also, I can’t believe WD would install a firmware update, after which all older WD MyBook disks (2 years in this case) can not be used for sharing data anymore. That would probably make a million USB disks useless for MyCloud owners?

I have since updated from 04.05.00-320 to 04.05.00-327 with no change.

Does anyone else have this problem?
I still think the reformatting somehow caused the issue… any hints what I may be doing wrong?

Thanks for reading, and any help is greatly appreciated!

This may be a dumb response. But did you try other share names? I noticed that your share name is the same as the device label.

MyCloud is creating this share for the USB disk automatically, and per default it uses the device name - I can rename it later but since the share creation failed, I never got to that step…

Does this mean that the MyBook does not get mounted?

It appears the disk is not mounted: MyCloud dashboard recognizes the USB disk and shows the device name, manufacturer, model serial number and firmware version, but the size is shown as “0 KB”. And of course it is not listed under shares.

When a USB device is attached. The my Cloud creates two mount points in the /mnt/USB folder. They exist even when the USB is not connected. It also creates an entry in the data base orion.db. There is a possibility that since the MyBook was connected before the reformat. It is having a problem when trying to enter the MyBook into the database.
If you can ssh into the My Cloud see what folders are located in the /mnt/USB folder.
You can also do the following:
sqlite3 /usr/local/config/orion.db
PS .schema Volumes;

will list the items in the Volumes entry.
.select * from Volumes;

This will list all of the volumes known to the My Cloud.

Thanks for the tips… my unix is a bit rusty and I probably do something wrong:

  1. I cannot see the USB folder in /mnt

WDMyCloud:/mnt# ls -l
total 0

  1. I don’t get the item list of the Volumes folder

WDMyCloud:/mnt# sqlite3 /usr/local/config/orion.db
SQLite version 2013-09-03 17:11:13
Enter “.help” for instructions
Enter SQL statements terminated with a “;”
sqlite> PS .schema Volumes;
Error: near “PS”: syntax error

Sorry the PS is for postscript.

the command is .schema Volumes;
What version of firmware is your My Cloud? I suspect it is 4.x. The 4.x does not have
any folders in the /mnt directory. Look in /shares for a gen1 firmware 4.x. On the gen1 I think the database is located at /DataVolume/shares/Public/orion.db
ls -l /shares
sqlite3 /DataVolume/shares/Public/orion.db
.select * from Volumes;

MyCloud firmware is v04.05.00-327.

The .USB folder shows 2 entries. I did a system restore this morning, which probably cleaned out all old entries? After that, I tried to connect my ‘problematic’ MyBook 4TB (without success) and for testing a Passport 1 TB which mounted fine and is currently connected and also shown in the shares directory.

WDMyCloud:/shares/.USB# ls -la
drwxrwxr-x 3 root share 4096 May 18 11:34 usb_2682A66E82A641E3
drwxrwxr-x 3 root share 4096 May 18 11:39 usb_6096-D67A

There is no orion.db at /DataVolume/shares/Public/
It is at usr/local/config/ as you suggested earlier, but
sqlite> .schema Volumes;
returns nothing…

I am new to sqlite but will read the .help trying to figure out what I do wrong…

I have connected 2 USB flash drives for testing, both were mounted and shared without problem. The content of the .USB directory looks unchanged after that:

WDMyCloud:/shares# ls -la .USB
total 16
drwxrwxr-x 4 root share 4096 May 18 11:39 .
drwxrwxr-x 11 root share 4096 May 18 19:10 …
drwxrwxr-x 3 root share 4096 May 18 11:34 usb_2682A66E82A641E3
drwxrwxr-x 3 root share 4096 May 18 11:39 usb_6096-D67A

However, the /var/local/autoMount/autoMount.db was apparenty updated each time…

OK. Not sure why you have a .USB folder. My 4.x system does not have one. I does have a STORE_N_GO_7 which is my USB device. My /DataVolume/shares/Public/autoMount.db contains the data below. You should have four entries or more. I think it keeps info on all USB devices it has seen.
0|2|Verbatim|STORE N GO|071058E90E5F9529|1.10|false|unsupported|unsupported|||unsupported|18a5|0245|1|2.0|480|1456888315.08779|||
sqlite3 /DataVolume/shares/Public/autoMount.db
sqlite> .schema Devices
connected bit,
handle int,
vendor text,
model text,
serial_number text,
revision text,
ptp text,
smart_status text,
lock_state text,
password_hash text,
password_hint text,
standby_timer text,
vendor_id text,
product_id text,
usb_port text,
usb_version text,
usb_speed text,
timestamp real,
devname text,
devpath text,
scsi_devname text

on my old system it is on /DataVolume/shares/Public/orion.db