MyBook 3TB drive not recognized, despite various methods to get it working

OK, so I started my PC this morning, and for some reason it was not reading my 3 tb mybook drive.

some background info: when i plug in the drive to a USB port, it generally makes some sound and spins up. this is still happening, despite it not being detected.

figured it might have been one of a few things. first i tried unplugging the drive from the usb port and putting it into various other ones. no luck

next i plugged it into a diferent power outlet, no dice.

I then plugged the drive into my macbook pro, and the mac couldnt see it. just to double check, i launched vmware fusion with XP, and attempted to route the drive to the VM. the drive was not listed in the usb listing.

thought this was a bit odd, so i plugged the drive back into my pc, booted into a linux live usb on my pc, and ran lsusb. according to lsusb, the computer cannot even tell that the drive was plugged in.

On 1 last attempt, I plugged the drive into a machine I have running windows server 2012. could not get it to detect at all.

the drive however, spins up when plugged into a usb port, stays at that point for a while, then spins down (I assume it spins down because of non use. it would do this when it was functioning properly).

this kind of makes me think that the controller for the enclosure is broken. its partially responding to being plugged in, so that makes me think the drive might be ok.

so what i would like to know is:

is it just a standard hard disk inside an enclosure? or is there some weird stuff going on in there.

I’d really like to pull the drive out, get it connected to a sata port inside my pc, and back everything up. im not too worried about the filesystem being damaged as I’ve recovered damaged NTFS filesystems many times in the past.

Connect drive using diff usb cable. Make sure drive is directly connected to a wall outlet. Check drive status under diskmanagement and device manager.

click start/rclick comp/click manage/disk management

click start/rclick comp/click manage/device manager     look for any yellow triangle, under universal serial bus controller

I’ve tried multiple cables, and the linux command “lsusb” is a command that checks all usb ports for devices, and lists info on them. same idea as what you’ve suggested (which I’ve also tried) with no luck.

If this is a drive that came with Smartware it will be hardware encrypted and connecting as an internal will only get encryted data if you get the drive recognized. Opening the drive also voids the warranty.


hey joe,

there is no smartware software on it as far as I know. I wiped the partition clean when i got it a year or so ago. I realize opening the drive voids the warranty, but the warranty has probably expired now anyways.